I have installed MS-DOS, FreeDOS and Windows 98 in Oracle VirtualBox. I want to try Commodore 64. How do I install a Commodore 64 emulator in VirtualBox?

  • 2
    Welcome to Retrocomputing Stack Exchange. It would be better if you rephrased your question as "How do I install Commodore 64 in VirtualBox?", otherwise the literal answer is "yes" or "no". Regardless, this is a good, albeit short, question. +1 from me.
    – wizzwizz4
    Jul 11, 2016 at 22:29

2 Answers 2


It's not possible. VirtualBox only supports emulating IBM-compatible x86 and x86-64 systems. The Commodore 64 uses a 6510 CPU and a wildly different architecture.

In order to run Commodore 64 software, you need a dedicated C64 emulator such as VICE.

  • 3
    I'm glad the Blind got an answer that helped him out, but technically this answer is wrong. The question is "How do I install Commodore 64 in VirtualBox?" The answer is, you install MS-DOS and then VICE for DOS. I just tried it in vmWare and although the question was for VirtualBox, I would be shocked if it didn't work exactly same way. I am not saying this is the best way to emulate a C64, but it can be done. Saying "It's not possible" is incorrect.
    – Geo...
    Jul 12, 2016 at 19:50
  • 3
    I don't think the answer is technically wrong. The OP stated that he had installed FreeDOS, MS DOS and Windows 98. It is no sense to install the three of them into the same virtual machine, so one can only assume he created three different virtual machines, each one with a different OS. So he wanted to add C64 to his list of machines, but obviously this is not possible, and that is what the answer states. Jul 12, 2016 at 20:47
  • But it is possible, albiet indirectly. The poster may want to keep a catalog of emulated systems as a series of VirtualBox vm's. You could just as easily have a vm for C64, Atari, Amiga and other systems. I'm not recommending it, but it is most definitely possible.
    – Geo...
    Jul 12, 2016 at 22:27
  • 1
    Isn't this an X Y question? The OP has (as is now clear from his reply) asked the wrong question by virtue of making an assumption that a VM solves everything. The SE approach seems to be that we are expected to answer a less specific question if that provides an easier solution to the inferred problem - and the OP can clarify that no, the convoluted meaning was intended by virtue of his specific use case. This then becomes a more useful question for people who encounter it in the future. Jul 13, 2016 at 12:42

Actually, if you really wanted to you could probably install MS-DOS 6.22 and then get VICE for DOS (http://vice-emu.sourceforge.net/index.html#download) working inside the VM. I don't know how well this would actually work, but once you had your Config.sys and Autoexec.bat worked out the VM could auto-boot right into VICE. I've thought about going this route as an experiment a few times, but I've never done it because VICE works so well right on my desktop.

This page (http://www.scampers.org/steve/vmware/) has a driver pack for MS-DOS/Windows 3.x hosted in vmWare, and I am assuming that some of the driver may also apply to VirtualBox, so I pass the link along in the hopes it may be helpful.

If you go down this path, I'd love to hear how it works out.

  • 3
    In case anyone is interested. I've done this experiment. It totally works. You can emulate a C64 in VirualBox or VMWare. The accepted answer is only correct in pointing out the disparity in architecture (6502 vs. x86). However you can emulate a C64 on a x86, so the answer to "How do I install Commodore 64 in VirtualBox?" is "By installing DOS and running VICE inside the VirtualBox".
    – Geo...
    Jul 26, 2016 at 23:38
  • 2
    Why stop there? Make sure you run the KIM-1 emulator on the C64 on the DOS on the host PC.
    – user12
    Jan 26, 2017 at 4:28
  • 2
    Eh, install Win7 on VirtualBox, run UAE on it for Amiga, then PC Task in it to get DOS, then VICE in PC Task.
    – SF.
    Jan 26, 2017 at 11:12
  • I mean, the real question is, why?!
    – Muzer
    Jan 26, 2017 at 17:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .