6

I replaced a failed CRT display with a LCD panel with a VGA controller board. There is no problem with the display when the PC boots up. However, if I switch the display off then I get an 'Out of Range' error when I switch the display on.

I have tested the display on two different machines and the problem doesn't occur. Both of those machines have a 640 x 480 native screen resolution. The display menu shows the 'Problem Machine' to have a 720 x 400 screen resolution. I checked and the VIA Apollo PLE133T chipset with integrated graphics supports a 640 x 480 screen resolution. Being a DOS only system I do not have access to the display properties.

Back in the Windows 3.? era the monitor refresh rate was set in either the autoexec.bat or config.sys. In my research I have found commands lines to change the resolution but they were ran in the Windows environment. I do not have Windows and installing Windows is not an option. I realize that this is a strange problem but I have exhausted my technical knowledge.

migrated from superuser.com May 22 at 8:45

This question came from our site for computer enthusiasts and power users.

  • All responses seem to overlook the fact that there is no problem with the display until the screen is switched off and on and that problem only occurs on one out of five computers that I have tested the panel on. The computer with the problem has a 720 x 400 resolution while the other computers have a 640 x 480 resolution. – Ron Becker May 24 at 13:23
  • @RonBecker If you don't think any of the answers address your problem then you'll need to explain why in better detail, as you've been given a couple of answers that explain how to "set screen resolution in DOS-only PC". – Ross Ridge May 26 at 19:55
  • @RonBecker Because you don't have enough reputation on this site to comment yet, in order to explain why in more detail you'll first need to merge your accounts so you can comment on your own question. meta.stackexchange.com/questions/18232/… – Ross Ridge May 26 at 20:00
  • @RonBecker my working assumption at least is that by setting a 640×480 mode all the time, you’re less likely to encounter the issue. It doesn’t explain why the display doesn’t sync after a power cycle; I imagine that the mode changes during boot up help it sync when the system is first powered on. – Stephen Kitt May 29 at 15:23
13

There are a number of tools you can use to tweak the display mode, including setting it to 640×480. The Free Software for DOS site lists a few, of which I’ve successfully used VBEHz and Text Mode in the past.

SVGATextMode, as mentioned by Radovan Garabik, would also allow you to configure your display in great detail.

The 720×400 mode you’re seeing is quite normal, albeit hard to support on plain VGA LCDs; it corresponds to VGA text mode 3, 80×25, with 9×16-pixel characters.

8

There is a Linux utility called SVGATextMode which can switch the resolution in text mode; there is also an MS DOS port, but you probably have to hunt for the binaries yourself.

EDIT: found the binaries (no guarantee!): https://www.ibiblio.org/pub/micro/pc-stuff/freedos/files/util/user/svgatextmode/svgatextmode_1_9_16rc1-dos.tgz

Read DOSPROGS.TXT inside the archive for instructions.

2

Problem may not be the resolution but refresh rate. On a VGA card the default text mode is the BIOS mode 3, which uses 720x400 mode with 70 Hz refresh rate. Many games also use BIOS mode 13h which is also 320x200 mode with 70Hz refresh rate. It may prove difficult to downgrade these modes down to 60 Hz, and even if possible, some programs may not work properly as they expect 70 Hz rate. For native DOS usage a monitor capable of 70 Hz modes should be used.

0

I would try UniVBE if it helps but its a long shot (IIRC I used version 5.3).

The problem is that the LCD driver does not support any VGA signal. CRTs are more flexible as they simply adjusted the sweeping frequencies but LCD doing all digitally and have more strict bounds on the frequencies and dot clock.

The text modes are not 640x480 but usually more and use a different timing. Sometimes swithing between modes help to re-establish sync (I think that is your case as on startup you claim it works). So what you need is to switch VGA mode to some that force re-sync the LCD driver and then switch back to text mode 3.

So either create some assembly utility or use Volkov Commander and hit ALT+F9 which switches between 2 text modes.

Not sure if switching between text modes help if not try a videomode (use any VGA demo from the demoscene)... You can associate it to menu in Volkov Commander so you can activate it blindly ... Here mine VGA 320x256 demo (escape exits)

so try to execute the com file and look if after exit (esc) the textmode work again or not.

btw. did you try to unplug and plug the VGA cable? That sometimes helps too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy