2

I'm trying to set up my system using UAE 4.2.1 64 bit and an excellent step by step guide provided by phraxoid:

https://devtty.io/2018/07/computing/how-to-setup-commodore-amiga-workbench-os/

The emulation is set up exactly as my real A1200. When using copy command in Workbench 3.1 shell the files are not copied and the only output is Copy Mode

UAE 4.2.1, A1200 Setup

I understand that some files are not properly handled in Windows as " " and other weird file names are not allowed, but since it is an emulation of the system, datatypes, and all it should not matter. Why it does it (not) happen?

  • 3
    I don't understand why you would get 'Copy mode' at all. Which version of UAE are you using? Can you show us the exact command you are typing? – Bruce Abbott Jun 28 at 4:20
  • 1
    Instead of taking a screenshot of the camera app on your phone, could you take a screenshot of the computer's display using the Prt Sc (print screen) button on your keyboard, followed by pasting into Microsoft Paint? (Or, you could use the Snipping Tool.) That'd make it a lot easier to read your shell window's contents. – wizzwizz4 Jun 28 at 19:56
  • Thanks for feedback – Bartek Malysz Jun 28 at 20:25
  • You are using the copy command from BetterWB, not WB3.1 (which explains the "COPY mode" message). In the screenshot we see that at least copy operation (Work:Temp/FBlit.info to SYSTEM:C/FBlit.info) did work. Copying WORK:Temp/FBlitGUI apparently did not work, however the text above suggests the source should be Work:Temp/Fblit/FBlitGUI. Can you confirm the path and that the file was there? Also in WInUAE what are your CPU settings (eg. cycle exact, fastest possible, JIT)? – Bruce Abbott Jun 29 at 4:57
1

It looks to me like your previous commands, before the failed command, resulted in you copying the entirety of the FBlit/ directory from your RAM:Temp/ source directory to somewhere else - and probably the somewhere else is System:C. Try:

List System:C/FBlit

It may show you have all the files there, which is not what the instructions meant for you to do. The instructions are attempting to put the binary FBlit in the System:C/ directory so that you can launch it from your Startup-Sequence file using C:FBlit.

Further, I don't think you have a RAM:Temp/FBlitGUI file because I think you extracted the LHA archive into an FBlit sub-directory, namely RAM:Temp/FBlit. So the copy command that worked for you on FBlit.info was you copying the .info file for the FBlit/ directory into your C: path. Also, not part of the instructions intentions. The instructions want you to copy the .info file for the binary FBlit.

Overall, I think the confusion started with FBlit/ (directory) vs. FBlit/FBlit binary inside that directory. TOO MUCH redundant naming, IMO.

-1

You are getting COPY mode because your Copy command has been replaced with the more powerful CopyReplace, which also has a MOVE mode and much else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.