3

I have an old Adaptec PCI SCSI controller from around 1995 (BIOS date, will get full model if needed). It's lived its life in an old 133 MHz Pentium from around 1995 as well.

The controller is 50 pin and has a CD-ROM and 1 GB HDD connected. The CD-ROM is on ID #2 via jumpers, the hard drive is #0 via jumpers and controller is #7.

There used to be Windows 95 on a second HDD which died, so I decided to reinstall on the current 1 GB drive. However, the PC will not boot off the CD-ROM nor hardrive. When I put in a Windows 98 SE install disk, Linux live CD, and custom MS-DOS CD, it says bootable drive detected but gets stuck after saying bios installed with a flashing underscore. I then took the controller and drives out and placed in a bit newer PC in which it booted right off the CD-ROM and then I installed DOS to the hard drive and booted and it worked no problem.

Placed back in original PC and got the same error. Set to boot off the hard drive and it says invalid partition table. What could be causing these errors? Since it works on the other PC without changing settings, it is confusing me. I feel the issue lies within PC, as the BIOS has no option to boot off external device, only A: and C:.

Unfortunately, I don't have a working floppy drive to boot off of to try that. I have tried all different settings in the Adaptec BIOS with no luck.

  • SCSI controllers have their own BIOS to support booting off SCSI devices, so the lack of boot options in the motherboard BIOS shouldn't be an issue. – Kaz Jul 19 at 8:57
  • "Set to boot off hdd and says invalid partition table." That's odd; the BIOS shouldn't care about the partition table, only at most whether (for old-style IBM PC MBR boot) the MBR contains a bootable signature and code or not. It's up to the code in the MBR to find the bootable partition and load the boot sector code from it to further bootstrap the system. (The exception to this is media that don't have MBRs, such as floppy disks and CDs, where the MBR part is skipped and the first sector of the media is the boot sector instead.) – a CVn Jul 19 at 11:24
  • Yes, the SCSI controller bios has CDRom boot enabled. It detects it an everything just hangs on boot. I was assuming the bios may be an issue because the other pc i tried it in has an option for bootable isa devices under the hdd settings in bios in which i must set to boot from to boot. – user2860253 Jul 19 at 12:54
  • Is a very strange error. I know some about MBR. Its not like it is corrupt or fornatted wrong because it works hmm. It is just odd because it works fine in the one pc making me believe the error lies within the pc itself. – user2860253 Jul 19 at 12:58
2

Here's a list of things you could try to narrow down the scope of your problem :

  • reset the BIOS of your PC and your SCSI card to default settings

  • remove all components except necessary ones to preform your test

  • try update the firmware of your PC, SCSI adapter and HDD (might be difficult for the latter)

  • try to change the slot were your SCSI adapter is inserted in (not all slots are created equal)

  • try a different HDD if possible

  • check whether your adapter requires PCI parity and enable it accordingly (e.g. a Matrox G400 in an IBM IntelliStation will never pass POST unless parity is explicitly enabled for its slot in the BIOS)

  • read the documentation of all hardware concerned, you might find relevant bits in regards to compatibility and requirements

I had the same problem except that it was the other way around, a 2004 LSI Logic U320 SCSI controller with a 15K RPM Fujitsu hard drive on an 1998 IBM IntelliStation M would pass the POST but then never be able to boot, this, until I tried another hard drive.

  • I have tried resetting both Bios and SCSI controller with no luck. I will try again though because i have since changed settings. I have tried with all removed but scsi controller and graphics card with no luck. Didnt try that after CMOS clear though. I also have tried in each of the 4 pci slots with no luck. I wish i had another drive to test. Parity is set to automatic on the SCSI controller didnt see option in bios. I will look. I dont believe its a compatability issue as the setup lived 10+ years together no issues. Thanks for your help! I will try your suggestions and keep it updated! – user2860253 Jul 22 at 0:07
  • 2
    If the setup already worked for some time then consider that some of the hardware is faulty! – Aybe Jul 22 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.