3

Trying to recover data from Conner CP341 HDD i took from an old Compaq Portable III.

The data is important enough to go through the effort of recovering it, and i would like to do this myself (rather than pay for a service to attempt it if at all possible).

I purchased a IDE to USB device and have tested it on an old Maxtor drive to confirm that it works. A drive letter was assigned to the drive and i could browse the drive via Windows Explorer.

I plugged the Conner CP341 into it and it says 'no drive found' in the software that came with the device, and no drive is displayed in Windows Explorer. I tried opening 'Disk Management' and i get a message saying the drive needs to be initialised and gives me an option for GPT or MBR. I selected MBR and got an 'Incorrect function' error box. I tried GPT but got the same result.

I have access to both Linux (Ubuntu 18.04) OS and Windows 10 OS. What are the next steps i can take to recover the important data from this old drive?

  • Start with trying to find a working CP341 HDD to test. It is possible that the electronics in the drive is more or less damaged... But the problem could also be that the IDE to USB adapter can't handle your drive. – UncleBod Aug 7 at 6:39
  • Did the drive still work in the Compaq Portable? Or was the portable not usable? – Stephen Kitt Aug 7 at 10:01
  • Last time it was used, about 10 years ago, it was functioning. I turned it on yesterday and a capacitor blew on the main board of the Portable III and it wouldn't start. This is all the info I have about the state of the hdd, except when I plug it into power via Molex it spins up and stays spinning. – Raptop Aug 7 at 10:11
  • 7
    Also, while not a data-recovery expert, I wouldn't accept any more offers to "initialize" or "format" the drive... if such attempts do manage to write to the drive, they are more likely to decrease the chances of recovering data than increasing it. – TripeHound Aug 7 at 13:06
  • 1
    A somewhat dramatic capacitor failure on power-up, with lots of smoke quickly released, is often traceable to a large film capacitor used to filter the input power. These are relatively trivial to replace. So, I wouldn't give up too easily on the Compaq. – Brian H Aug 7 at 15:00
7

The hard drive is so old that it pre-dates the era of auto-detecting the drive parameters. If the USB adapter cannot determine the correct drive parameters automatically then there is no way to force the parameters. Connecting it to a PC where you can manually set the drive parameters in BIOS is the fastest solution. The standard drive parameters should be 980 cylinders, 5 heads and 17 sectors per track, but the MBR and FAT partition should reveal what parameters were in use on the original system.

4

@Justme has covered the topic of drive detection, but since the question is requesting "next steps" for data recovery I'd like to speak to reading the data once your hardware is able to "see" the drive.

As you have access to Linux, I highly recommend using GNU ddrescue for reading the disk especially given its age. ddrescue will create an image of the drive or partition which you can then mount and work with. This way you only have to connect the drive once but can go back to the image as often as you need or want.

Ubuntu provides this with the gddrescue package.

There's a good tutorial at linux.com but here are two sample commands:

sudo ddrescue -r3 /dev/sdb1 cp341partition.img logfile

This will read the first partition of the disk mounted as sdb and write it to cp341partition.img, logging progress to logfile and making 3 attempts to recover bad blocks. This is most useful if the disk only has one partition and no additional tools are needed. The result can be mounted with mount -o loop,ro cp341partition.img /mnt/dir.

sudo ddrescue -r3 /dev/sdb cp341disk.img logfile

This will read the entire disk mounted as sdb and write it to cp341disk.img, logging progress to logfile and making 3 attempts to recover bad blocks. This images the original MBR and all partitions in one file. This is most useful if you have multiple partitions and is a little more complex to mount, my recommendation is to use kpartx (Ubuntu package kpartx). The result can be mounted with kpartx -av cp341disk.img -r.

Note that in both cases this mounts the image read-only for safety.

  • 1
    With a 40 MB drive, I'd make copies of the image file for extra safety as well as mounting read-only. – a CVn Aug 9 at 13:23
1

From another good answer: "Connecting it to a PC where you can manually set the drive parameters in BIOS is the fastest solution."

Hint for finding such a PC: The facilities to manually set such parameters in the BIOS setup will often be present in mainboards that are equipped with ISA/EISA slots. Such boards still physically supported some ancient ISA/EISA connected ESDI or ST506 disk controller cards (these were actual disk controllers in function, not host adapters) that always needed such configuration to be done, so there was a reason to keep the options. A PCI or PCIe only board cannot support any such controllers, which is why the options were likely removed, ignoring first generation IDE drives that need the same support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.