8

I recently got hold of an old Pentium based machine (IBM 340) and started with a blank slate by formatting the disk. I also added a Soundblaster AWE32 which is a value model, specifically the CT3910.

I was having an issue where running Creative's DIAGNOSE.EXE would throw an error when trying to scan for the MIDI address, 0x330 (which is what's configured) and the other option (0x320?) would both fail and I'd get no further. If I ran DIAGNOSE.EXE with the switch /DPMU which I think stands for Disable MPU then it'd work fine, and all the sound tests (samples & MIDI) would work. Following this I could play games with sound, but even when I let it modify the system startup files I'd have to run through the process again after rebooting.

Given that the MPU should be enabled according to the jumpers I removed and added the jumper again to test for a bad connection. Now DIAGNOSE.EXE no longer fails and doesn't need the /DMPU switch, but I still don't get MIDI music in games until I run it.

I can only assume that the program is doing some initialisation on the card that's making it subsequently work; even with the correct settings and calls (including DIAGNOSE /S) in my autoexec.bat I can't get music in games until I run the program manually and in full.

MIDI In Windows 3.1 does work without running it, and I believe this is because it's using Creative drivers. Does anyone know what I need to do to have this card initialised correctly on startup?

  • Perhaps it needs to be run last? Could we see your autoexec.bat (assuming it's not too big)? – wizzwizz4 Jul 28 '16 at 7:34
  • From my memory of using Soundblasters 20-odd years ago, the drivers changed with every new card release - almost monthly, and that no two cards were the same. – Chenmunka Jul 28 '16 at 10:21
3

So hunted around some more online, and it seems as though Chenmuka was correct in that it was related to the tools I was using to configure and manage the card.

I replaced AWEUTIL.EXE with a newer version (1.20 to be exact), which is one of the tools used to initialise the card from autoexec.bat. This newer version initialises the card properly and now all my games have MIDI audio from boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.