2

I have a ZX Spectrum+2 with the built in tape deck. I can load tapes no problem, when I try to save, I get the border lines. When I try to reload the program I get nothing

Any help would be greatly appreciated

  • When you are saving to an empty cassette, is there something on there afterwards? – tofro Sep 7 at 20:06
  • 1
    Can you hear saving noises (beeeeeeep prick ..... beeeeeeeeeep pripripri....) through the TV? Can you hear the same noise when trying to load? – mcleod_ideafix Sep 7 at 20:22
  • I used a Fresh tape. When I save I get the border flashing and all the noises. On loading the border flashes slowly red and blue with no sounds. – Alistair Sep 7 at 20:38
  • 1
    Seems to be a problem with the recording to me. Check cables, try to record something else (music or your voice), ... – the busybee Sep 7 at 21:02
  • Do you get the noises when listening on a regular player? If yes, then the input part may need to be adjusted. If not, then the recording itself doen't work. If only very faint, then level needs to b adjusted - or wrong tape material. What cassettes are you using? – Raffzahn Sep 7 at 22:09
2

Incorrect head alignment, dirty saving head, "dry" solder joints, oxide deposits on the head(s) over the years. Many things can have gone wrong over the years.

People usually prefer opening the Spectrum up to clean the heads, as many do not trust cleaning tapes. I would try to align and clean the tape deck heads as a first effort.

If that does not work out, it might be a (slightly) loose cable, and it will involve opening the computer and inspecting it.

  • You definitely want to avoid "cleaning tapes"; they rarely do a good job and some can even be harmful. You shouldn't need to open up the computer to clean the heads; just push the eject button to open the cassette lid and use a cotton swap soaked in 90%+ isopropyl alcohol to clean the record/play heads, the erase head and the metal capstain and other metal parts. Don't get alcohol on any rubber parts. Head alignment shouln't be attempted unless you have a proper alignment tape, but if you're playing back tapes recorded on that system the head alignment won't be an issue anyway. – Curt J. Sampson Sep 9 at 15:00
0

Silly question but you're pressing Record and Play together, right? Then press any key!

The tape head isn't likely to be faulty since the same head records and plays. Recording though, requires the tape to be blank, so an erase head does that. You could try erasing a tape in another tape recorder (ie just record nothing onto it, perhaps stick a mic lead in there with nothing on the other end {this would all be stuff you'd have if you had a Speccy 48, probably not otherwise!}. Use an old stereo system to record nothingness onto a tape.)

Then try recording onto this newly-blanked tape. Make sure the little holes on the top edge of the tape, where there are little tabs you can break off, are not empty. IE the tabs are still there! Obviously a pre-recorded tape has no tabs to start with. The tabs are write-protect, for tapes.

What are you trying to save? Saving a program from BASIC, even

10 print "I AM GREAT!"
20 goto 10

would do.

SAVE "IROCK"

to save it. Will be a short one!

Then... I don't need to tell you how to load something!

It's really confusing. The border gently flashing red / cyan just means "not a peep on the tape, not a sausage". The tape is moving, when you save, and when you load?

Since the record and play head is just one head, this is very confusing! You will check the tabs at the top, won't you? Record button shouldn't even go down if they're missing.

A really weird possibility would be something has gone in the record circuit. IE obscure hardware problem.

  • Thanks for your contribution! I edited your post to indent all the code lines by four spaces, which formats them as code blocks in the question, making them much more readable. (You can see the exact change by clicking the "edited ... ago" link at the bottom of the question.) You can see more formatting hints on the formatting help page. – Curt J. Sampson Sep 10 at 5:03
  • To answer the stupid question, yes I am pressing play and record. I tried the short basic program here, it gave me the save tones and lines. When I tried to reload I only got the red and cyan border and a very scratchy sound, like the recording was very faint – Alistair Sep 10 at 16:00
  • Hm. Sorry to say, sounds like the tape drive is buggered then. There are places online that fix Speccies. What about using the sound port on the back to connect to a tape recorder for recording? Then using the internal drive for playback, since it works? That is, assuming the sound port doesn't have the same problem. Yeah I realise it was a bit of a stupid question but the problem is very basic and fundamental, just trying to eliminate the possibilities before declaring it broken. – Greenaum Sep 13 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.