5

I am trying to get an Amiga 3000T up and running, all seems good but there's no Fast RAM. All Zips ard populated. Is there any (easy) way to test the ZIPs? Also, could something like a bad cap kill the Fast RAM? An alternate Ramsey was tried.

  • 1
    Is there a jumper on J852? It indicates if the ZIP RAM is either 256Kx4 or 1Mx4. If no jumper, it might not be recognizing the RAM at all. – bjb Sep 24 at 18:41
  • 1
    Yes, jumper is present, and tried in both possitions to test. – Zenzizenzizenzic Sep 24 at 20:57
4

There can be all sorts of reasons for this that you will need to investigate.

You can start by measuring the voltage between pin 5 and 15 (GND and 5V) to make sure they are being powered. If you have an oscilloscope check for activity on all the address pins too.

The only way to test ZIPs is to put them in another known working machine. If you don't have one you can swap them around to see if it's just one that has failed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.