4

El-Fish is a fish tank "game", where you have virtual fish on your screen. The game has no goal, it's more like an interactive screen saver.

I got my version from a number of different sources, one was Vetusware, but since no copy I got worked, I tried a number different ones - however literally none of them worked in the end.

I'm trying to install El-Fish on an MS-DOS 6.22 VM (Virtualbox). The VM otherwise works fine, including Windows (for work groups) 3.11, networking, CD-ROM, sound, etc.

When running the install.exe from whatever install media, it hangs, doesn't read any of the drives, and just sits there. When I remove the install media drive, it brings up an error message that install.prg cannot be found (that file is in the root directory of the install media, right next to install.exe).

I was wondering if this is a known issue, and whether there's a trick I could use to install the game/screensaver without going through the installation routine.

when running file elfish.pkd on my Linux host it returns: elfish.pkd: Biosig/Heka Patchmaster. So, some sort of archived directory structure, I assume?

The install.prg file, is some sort of script file, similar to an NSIS install script, as far as I can tell. Since it's an ASCII text file, I've uploaded the text here (paste binned): https://0bin.net/paste/raBfhFIfDBj7l05W#HnJnyE9RnJ0q8aJhFqL-/C8B4HGx2thxY8LztFf4XTd

The goal here, is to get the software unpacked and installed, if I can just get the files to decompress, I can simply copy the files over to the target MS-DOS computer or VM, respectively.

2

I haven’t tried VirtualBox for this, but DOSBox runs the installer fine:

  • copy all the files on the installation disks to a single installation directory, e.g. ELINST (in a temporary directory) — you’ll end up with ELFISH.PKD, INFO.EXE, INSTALL.EXE, INSTALL.PRG, and READ.ME, along with a DATA subdirectory containing 122 files;
  • start DOSBox in ELINST’s parent directory;
  • inside DOSBox,

    cd elinst
    install
    
  • follow the prompts, choosing the resolution, entering your name, and choosing the installation directory;

  • wait for the installation to complete.

This will leave a fully-installed and configured copy of El-Fish in the installation directory you chose; you can copy this to your VM.

  • It seems the problem is, that I'm using a CD-ROM image to install from. The packed files have a .$01 extension, the ISO9660 filesystem doesn't like the '$' in the name. There is still a number of problems, though. It takes forever for the install routine to start (and elfish, too). And it doesn't recognize the "high resolution" capability. I manage to install it for now, but it's still not really satisfactory. I've yet to figure out a way to not install it from individual floppies. – polemon Nov 15 at 13:18
  • The lack of “high resolution” is probably caused by the emulated display in VirtualBox, which isn’t very good for older operating systems. – Stephen Kitt Nov 15 at 13:23
  • I got it to work in the "unsupported" mode! I had to edit the INSTALL.PRG, I might distribute the changes. Things still don't work how they should though. The number of hoops I had to jump through up until now plus there's plenty of things that are not working right, like whenever elfish or the install program are run, it takes a (indeterminate?) number of key presses and time, Anyway, while the install program doesn't detect the video capabilities correctly, the actual game does - or at least seems to. – polemon Nov 15 at 15:19
  • Did you give it a shot with DOSBox? – Stephen Kitt Nov 15 at 15:31
  • Nope, I specifically want this to run on VirtualBox. The reason being, I might wanna move this onto hardware. However, I may not be able to find all the software for whatever hardware I'd use. Now, the requirements aren't really stringent. It works on basic stuff. The process of getting it installed however is quite cumbersome and annoying. Not least because the install script is written very confusingly, and doesn't really detect post-386 hardware well enough. – polemon Nov 15 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.