5

I have purchased a 64GB compact flash UDMA card and am unable to boot up in DOS.

The machine I'm running has a Pentium 1.6Ghz process in it just to give you an idea about how "modern" it is compared to say, a 486. The BIOS can see the drive fine.

If I boot the machine using a Windows 98 SE floppy disk (or even a DOS6.22 boot disk), DOS can see the drive perfectly and I can easily work with files.

I have run clearhdd.exe and fdisk.exe to set the drive up, which worked without any problems at all. After that, I used the format c: /s command which successfully worked and copied the files across.

When the machine boots up though, I get a black screen with a blinking cursor, that's it. I have successfully used a 4GB CF card with this same machine and it booted fine which leads me to believe it's the CF card, however, DOS can see it perfectly.

I suspect that it's not booting because it's looking at the wrong "sector" or part of the disk responsible for booting? I'm not sure.

Any advice would be appreciated.

  • Is the card programmed with an MBR with boot code? Did you run "fdisk /MBR" to rewrite the boot code to sector 0 ? – Justme Dec 9 '19 at 11:08
  • 1
    @Raffzahn I had a non-MMX Pentium 200, and it looks like there were also pre-MMX 0.35µm runs at 133Mhz, 150Mhz and 166Mhz. All Socket 7, mostly released in 1996. Probably I've misunderstood what counts as a straight Pentium. Definitely I've decided to run off into the long grass with this irrelevant response. – Tommy Dec 9 '19 at 16:29
  • 1
    @Tommy Well, I tried to draw a line on before MMX but yeah, it's a blurry one. And you're right, there was the P54CS with 66 MHz and up to 3.0 multiplier, but AFAIK only available for direct soldering, like in laptops. Then again, They cranked out everything imaginable to hold against AMD, so yeah, maybe there were PGA versions as well. – Raffzahn Dec 9 '19 at 18:11
  • 1
    @Raffzahn I have a pre-MMX, 200MHz PGA socket 7 Pentium, so yes, they were available as desktop CPUs at that speed ;-). The MMX version went up to 233MHz. – Stephen Kitt Dec 9 '19 at 22:02
  • 1
    @StephenKitt I stand corrected. It was a time of much variation, wasn't it? – Raffzahn Dec 9 '19 at 22:30
5
  1. Check the MBR record. Did you use the "fdisk /MBR" command?
  2. Some of those cards do not support the CHS mode (Cylinder / Head / Sector), especially the larger ones. Try the smaller card.
  3. Check if the BIOS supports the LBA mode. Some older BIOSes can't...

Generally, booting from the hard disk (or CF in this case) perform reading MBR from the very first sector of the disk. There is a small routine (just a few hundreds of bytes), which looks into the master partition table (it is a part of MBR too), find a bootable partition, reads its boot sector and perform a boot code from this sector. Reading the very first sector should be easy, but maybe there is a problem finding the bootable partition.

|improve this answer|||||
  • 1
    fdisk /MBR has not solved the problem, which is unfortunate. I'll see if a 32GB card works, and keep reducing the size until I find the magic number. The BIOS definitely supports LBA. Whether or not the CF card supports CHS mode is irrelevant right now because it's obvious to me that it's the card, not the hardware or the MBR. Thanks for your help anyway. – Vince Panuccio Dec 13 '19 at 9:56
3

I've run into that issue before. Try a smaller card. Some systems do not like to boot off of cards greater than 16 GB. Some 32 GB...

|improve this answer|||||
  • 1
    Follow-up query: would it be safe to assume such systems are failing even to load the boot sector? – Tommy Dec 9 '19 at 16:32
3

Out of all the things I tried, what ended up working was:

Copy Windows 98 set up files to the CF card. Let windows do it's thing, and boom, it booted from the CF card.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.