2

Modern Computer communicates with a 34-year-old Panasonic KX-W50TH

The Challenge

I have a Panasonic KX-W50TH thermal typewriter with a nine pin serial interface port on the side. I have a RP-K105 interface connected to my Windows 10 computer using a Sabrent USB to Parallel cable. I set up a generic text printer and set the print processor up to auto form feed. My first transfer from the computer to the typewriter was Hello world!. On the typewriter I got Hlowd. Using a Linux computer I get the same result with is copy a file to /dev/usb/lp0. The text sent is missing characters.

To be clear, the link between a modern computer (Windows 10 or Linux) and the typewriter is being made. The issue is that every other character is missing when sending output to the typewriter. I think a configuration setting on the modern computer is the issue. At the typewriter, I cannot make any configuration edits other than CODE+T (turns on or off the terminal mode). The only changes that I can make with the interface are to switch it on or off and to bring it online or offline.

I have successfully sent data to an Olivetti 900x with the USB to parallel cable using Windows 10 and Linux.

Any thoughts? Has anyone else tried this? The Panasonic typewriter is an amazing device.

2020-01-22 Edit: Type Specimen added. I do not think that the typewriter is using the original ASCII set. The additional characters in KBII and KBIII are part of the Extended ASCII set.

Photos

Type Specimen

Parallel Port

Typewriter data port and the interface plug

kx-w50th

RP-K105

Helpful hints

  • 1
    Since you have two interfaces here, one thing you can do is plug the output of the RP-K105 into a different serial port (say, a USB serial interface connected to a computer) and check the output of that. If it's correct, the issue is with the typewriter or its serial port settings. If not, the issue is with the parallel output, the parallel-to-serial adapter, or you've not correctly set up the serial interface you're using to test it. – cjs Jan 22 at 5:59
  • I tried your idea. I routed the serial port back to my computer, and used a gender changer and a NULL modem adapter (separately and together) to make the connection. I cannot see any text when the print job is run. I tried 1200, 2400, and 9600 baud on the serial port. – Linus Jan 22 at 7:08
  • 2
    You may or may not need a "null-modem" adapter to reverse TX and RX. If you see nothing at all, it sounds as if your computer may not be asserting appropriate flow control lines, though. Did you use a terminal program on the computer that (one hopes) would do this for you? (The easiest way to debug something like this is with a serial breakout box or even an oscilloscope, but that gets pretty involved....) – cjs Jan 22 at 7:19
  • 5
    Also, interesting that the manual suggests MODE LPT1:,,P, which is described as, "...tells DOS to continuously try to send output to the printer if a time-out error occurs.... An example is when the printer returns an out-of-paper error. If you have used the P option, the computer will continue to try to send while you refill the paper supply." I wonder if there's a handshaking issue? – cjs Jan 22 at 7:19
  • 1
    Missing characters indicate that the KX-W50TH interface (whatever kind it is) has some kind of "busy" signal that is not respected in your RP-K105 - Parallel - USB chain. A first step would be to figure out what the KX-W50TH interface actually is; if it's some kind of semi-standard serial interface, you could connect it up in a more direct way. If you know someone with hardware to analyze the signals on this interface (e.g. oscilloscope), that would definitely help. – dirkt Jan 26 at 6:36
2

I would assume the serial interface is something proprietary. If it was anything close to a standard RS-232C, they very likely would not have bothered with the whole parallel interface contraption.

The Sabrent USB-Parallel cable ends in a DB25F. So you have a DB25M - Centronics 36 cable. I would try swapping that first. I have seen plenty of flaky parallel cables over the years, and it is quite possible that it works "good enough" (so you get some output) but that a handshaking line that the Panasonic needs (and maybe the Olivetti 900x doesn't care about) isn't working.

The next option, but which is not as cheap/easy as another cable, is a PCI Parallel card: enter image description here

Of course, that is dependent on having PCI slots. If you are using a laptop then that's not an option, and there are plenty of desktops that don't have expansion slots any more either. The idea is that Windows is controlling the port much more directly (like DOS did) than via a USB port where it is really sending commands to a microcontroller that is in turn running the parallel port. I have more hope for proper handshaking with a PCI card than with a USB adapter.

  • 1
    I have to think about this. I was wondering what you think about a ethernet to parallel port print server. My laptop does not have the capability to work with the card that you suggest. If I had a computer with expansion slots, it would work well. What do you think of the print server idea? – Linus Jan 23 at 7:21
  • 2
    @Linus It's worth trying a different model of USB cable, a print server, or whatever else you have to hand that's cheap, but keep in mind that's all just random tweaking in the hope that the problem will go away with some sort of change. If you really want to get this solved, you may need to get hold of an oscilloscope or some sort of logic analyzer (even if it's just something hacked out of an Arduino). – cjs Jan 23 at 11:46
  • 1
    An ethernet-to-parallel print server should work well. I am pretty sure I tossed the last of my old HP Jetdirects years ago - haven't needed parallel for a while - and when I do, I put in a PCI card. – manassehkatz-Moving 2 Codidact Jan 23 at 22:54
  • 1
    I ordered an ethernet to Centronics print server. In a few days I will know if your suggestions will work out. Confidence is high that the solution proposed will work. The solution will allow a lot of customization of the settings. Currently, I do not have any customization for the USB device. – Linus Jan 24 at 0:38
2

The Solution

I added a StarTech PM111SP2 print server, and changed the print speed to slow. Here is a video of it working for the first time: Printing for the Very First Time

Print Server

The Solution

Text from the first successful digital transfer

Hello world!
It works.
I have a Panasonic KX-W50TH thermal transfer typewriter that I wanted to use in the modern world as an internet of things printer. The typewriter was manufactured in 1986 using technologies that are not common today (2020). How can a computer from today work with a typewriter that was manufactured 34
years ago? The Panasonic KX-W50TH uses a separate interface adaptor. In 1986, the optional adaptor called out in marketing literature is the RP-K105 (edit: RP-K100). A search for this adaptor resulted in a dead-end. Parts suppliers for Panasonic list it as no longer available. A substitution part is listed as RP-K105. This adaptor is also no longer available. By sheer luck, I managed to find one on E-bay that was for sale for months. I visited the page long before I got the typewriter. I purchased this rare interface adaptor and hooked it up to my computer using a USB to Centronics cable. The cable was successfully used with an Olivetti 900x typewriter.

This is my original configuration:

  1. Computer
  2. USB to Centronics Cable
  3. Panasonic RP-K105 Interface Adaptor
  4. Panasonic KX-W50TH

I set up a Generic Text Printer and selected the USB port in the ports tab. MY fist (Edit: My first) printing of "Hello world!" printed, but it looked like "Hlowd". Based on the discussion on the website retrocomputing.stackexchange.com (See panasonic-kx-w50th-data-transfer), it was suggested that I use a different cable or a PCI card. I opted to purchase the StarTech PM111SP2 print server. The print server is a networked device that connects to a Centronics port on older printers.

My new configuration is the following:

  1. Computer
  2. Network
  3. StarTech PM111SP2 Print Server
  4. Panasonic RP-K105 Interface Adaptor
  5. Panasonic KX-W50TH

Once I set up the print server and configured it, I added a new port to the Generic Text Printer on my computer. In the Print Server Admin, I changed the print speed from Fast to Slow. I printed "Hello world!", and I saw the same result on paper. Any print speed that is higher than slow results in missed characters.

We are good to go!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.