3

I found abandoned IBM Thinkpad 560X inside of company's cabinet. So, I got curious and get generic AC-DC SMPS adapter for 10$. It was rated 16V 3.75A, diameter for plug is just right, and polarity was center plus. Just like laptop wants.(560X required 16V 1.9A) According to that, it should work.

But when I connected adapter to laptop, it doesn't power up. Plus, adapter's power indicator LED doesn't stay on. It was doing kinda flickering, but very faintly.

I got freaked out, and disconnected it from laptop. After that adapter's indicator LED was lit steady. Plug in to laptop again, and still flickering.

I can't understand why this happening. Usually flashing indicator LED means that PSU is struggling to push power into device, but in this case, PSU is 60W, and 560X requires about 30W. There's plenty room for wattage.

Is it SMPS adapter laptop wants? Or laptop power adapter is different from generic SMPS adapter?

5

I would say that it is more likely that the laptop was shelved because it's internal power circuit is at least partially shorted. This would explain the symptoms observed from the power supply LED. I, personally, have run into several laptops that had this problem.

I would test the power supply under some sort of resistive load, such as a 12 Volt automotive headlamp or bright brake/turn-signal light bulb. If the power supply successfully powers the bulb, then the laptop is the likely culprit.

4
  • 1
    Use a meter on continuity test to test the notebook input for shorts. If the input has been overvolted or exposed to reverse polarity, it is very common for the suppressor diode to short out. Feb 7 '20 at 7:33
  • @Hitek I didn't know that can be happen. Then I'll get multimeter and check power input port. Also, another known good Thinkpad is now on delievery, I'll test PSU once again with it.
    – Kamome
    Feb 7 '20 at 15:04
  • Also I've asked seller for PSU about symptoms, he said that PSU's protective circuit makes LED blinks. If laptop's internal power circuit was bad, then PSU did it's job well.
    – Kamome
    Feb 7 '20 at 15:12
  • I got working TP 380E and adapter is working perfectly! It seems 560X have some issue in PSU part. Thanks everyone!
    – Kamome
    Feb 13 '20 at 15:00
7

I think you have a fake or mislabelled adapter.

These symptoms seem to me to be those of a cheap adapter that's browning out when it's trying to supply the current the laptop wants at the voltage it wants, which is something that fake or mislabelled adapters would certainly do.

3
  • 2
    I read customer comments in seller's page, and it seems some people have experienced faulty case about PSU I bought. I'll get replacement from seller, and if it doesn't works either, I'm gonna refund it.
    – Kamome
    Feb 6 '20 at 10:03
  • 1
    @Kamome If you have a multimeter (even a really cheap one), it's worth testing the voltage output of the supply while it's plugged in; if it sinks more than a little below 16 V that would indicate that the laptop is drawing more than the supply can deliver.
    – cjs
    Feb 6 '20 at 14:39
  • Also, if you can get access to an oscilloscope, you can monitor what the SMPS is actually putting out.... Feb 6 '20 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.