2

I'm trying to install and use the Arachne broswer under DOS (6.22). I've DOS installed on VirtualBox VM (5.2.34) under Linux Ubuntu (4.15.0-88-generic #88-Ubuntu).

I'm in trouble in configuring network and TCP stack on the configured DOS virtual machine.

I've tried to configure the network with all kinds that virtualbox allows, but I think that the problem is that I am not able to remember how to configure the network under DOS.

I tried to install NE2000 or NE2100 or 3C509 drivers, but I'm not able to individuate the IRQ and port where the virtual card replies. I've tried a lot of IRQ and port combinations, but nothing runs: PORT 280,300,320,340,360 IRQ 3,4,5,7,9,10,11.

NE2000 and NE2100 drivers replies always: "My Ethernet Address is FF:FF:FF:FF:FF:FF" (where FF:..:FF should be the MAC address).

3C509 driver replies: "No 3c509 found. Use a different id_port value. Default is 0x110."

Furthermore I'm not more able to use/configure NETBEUI.

Do somebody has a good solution!?

  • 1
    PnP is not very strong on DOS, I think this emulated NIC should be somehow given to the DOS drivers. It probably it requires some setting in the config.ini, and some corresponding setting in the virtualbox (possibly these vbox settings are available only in the xml config file of the VM). – peterh - Reinstate Monica Feb 23 at 18:33
  • 1
    You might also try DOSEMU or DOSBOX, they are probably better in ISA (or non-PNP) settings. – peterh - Reinstate Monica Feb 23 at 18:35
  • @peterh-ReinstateMonica Does DOSEMU and DOSBOX provide a full network stack? I would guess that an IPX network was provided directly by the emulator. – Thorbjørn Ravn Andersen Feb 24 at 14:25
  • @ThorbjørnRavnAndersen As far I know, they do not. But the ethernet NIC gives as ethernet-level interface, i.e. we can send and receive 802.3 packets by bios calls. It has same port/irq (maybe DMA) settings, these need to be configured in the config.ini . Possibly there is some .sys file to provide a tcp/ip, it might be given by the emulators by default or not. Autoconfig provided by pci or isa-pnp is probably not supported. (Ps: welcome back :-) might you consider a vote change here? I improved the post to not suggest com.sun.* any more :-) ) – peterh - Reinstate Monica Feb 24 at 14:32
  • 1
    My hazy memory was that you needed NIC drivers for the nic you are emulating that would have the network stack, but then you would need a protocol application to actually transfer the files. FTP, or TFTP. This is well before ssh. Netbeui would only work in Windows in 6.22. you could possibly mount virtual files via a CD, but most of my experience at that time was on a netware network(IPX) which was designed to transfer files to and from the netware server. I know you want to run dos, but you should really look at the dos in 98se for a more robust file share capability. – Rowan Hawkins Mar 7 at 7:29
4

The network card driver needs to correspond to the hardware emulated by virtualbox and neither of those you have tried, do.

Full instructions seem to be present on the VirtualBox wiki - https://www.virtualbox.org/wiki/Sharing_files_with_DOS

Be especially aware of the extra step to have bridged network.

  • Back then I had success in using NCSA telnet to have several telnet sessions running on a 8086 PS/2 machine with an 8-bit netcard. My preferred program MS-Kermit was too slow for this. Enjoy 🙂 – Thorbjørn Ravn Andersen Feb 23 at 13:16
  • Think, I used the first PC IBM with Token Ring and DOS 2.0 (if I correctly remember). But at now I don't remember a lot of facts. Also PROCOMM was in my memories with kermit ... FIDONET ... ;) – Sir Jo Black Feb 24 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.