0

I've acquired a late-80s portable 386 with builtin LCD in unknown working state. It only ever beeps continuously on boot, with no picture on either the built-in LCD or an external VGA-connected monitor.

Relevant details: 386SX-16, AMI BIOS, SIMMx4 and DIPx36 (8MB, I believe; I'm having trouble locating the chips online).

I've desoldered and cleaned up a leaking rechargeable 3.6V CMOS battery and tried replacing it with a coin cell to the appropriate headers w/ jumper setting for external battery.

I've tried pulling all the RAM in various combinations (obeying the manual's instructions about which banks to leave empty when doing so and how to set jumpers).

At the base level, I'm trying these things with the external CMOS battery and the video card hooked up, but I've removed all the other ISA cards: serial/parallel, disk controller, and a NIC.

I've confirmed that the AT power supply has proper ground, +/-5V, and 12V, and the fan is coming on when it is hooked to the system.

As best I can figure, the single, continuous beep indicates a RAM and/or video problem.

What should I try next? Any ideas on what else could be wrong?

  • 1
    Are you sure the video card is healthy and/or working properly? – Sir Jo Black May 1 at 7:14
  • 1
    A continuous beep seems more related to the functioning of the motherboard than the bios. – Sir Jo Black May 1 at 7:26
  • 1
    Indeed; problems like memory or video issues usually have a repeating code of short or long beeps. A continuous beep probably indicates that the system is unable to get as far as running the BIOS POST code, which means either a motherboard or processor failure. – occipita May 1 at 11:33
  • 1
    I’m not positive the video card is healthy. I don’t yet have access to another ISA one, but I will try to acquire one. – incanus May 1 at 16:16
  • 2
    It's not true the assumption that beeper cannot sound without BIOS. Some motherboards emit continuous sound to signal faults (I.E. the absence of components such the BIOS). – Sir Jo Black May 1 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.