4

I have acquired a Zenith SupersPort 286e without its battery but with its (seemingly working) power supply.

Sadly, the computer doesn't boot at all, nothing happens when I flick the On/Off switch. The power supply seems to work as it does a small white noise when plugged.

I have disassemblied it and everything seems intact, no rusted or corroded parts, everything looks ok.

The only thing that seems missing is a chip under the computer that is accessible via a small screwless trap. There is a 40 pin socket (2 rows of 20 pins) that measures 1.8 × 5 cm.

This is the only thing missing, and I think its only an extension as it can be accessed without disassemblying the computer.

What could be the cause the this Zenith SupersPort 286e not booting at all? What component could be dead (motherboard, CPu, hard drive...) that could cause the computer to not do anything when turning on the computer?

6
  • 3
    A common cause of failure in old electronics is electrolytic capacitors. Have you inspected the large capacitors in the power supply (carefully, since if they haven't failed, they can give you a nasty shock) for damage or leakage?
    – Mark
    Commented Sep 25, 2016 at 17:30
  • 3
    I opened the external power supply and after checking everything for a while, I noticed a dried out brown liquid at the feet of two capacitors that are next to each other, could this be it? Also, it would mean that the problem doesn't come from the computer. But I've never replaced capacitors or did any precision soldering for that matter, so I don't know how I'll do as all the other external power supplies I have doesn't match the computer's requirement (16.5 V). Commented Sep 25, 2016 at 18:59
  • That definitely sounds like its at least part of the problem. Hopefully the bad power supply didn't kill anything in the computer. Luckily if its just the external power supply you could try to find a replacement, or ship it out to someone who can repair it a lot easier than shipping the whole computer.
    – mnem
    Commented Sep 26, 2016 at 3:37
  • Apparently 16.5 V power supplies aren't common, I couldn't find a bunch of them. So I'll check out how I can fix all of this. Commented Sep 26, 2016 at 20:04
  • I have one too. Similar fault also.... Commented Sep 30, 2016 at 22:21

1 Answer 1

2

After further inspection of the internal components of the computer, it seems like the internal "power managing" component where the electricity input is is dead.

There is a fuse that is blown and some capacitors are leaking a brownish liquid.

The reason for the computer not booting seems pretty obvious now. I'm not sure I'll be able to repair it as I've never disoldered electronic components and replaced them.

I'll see what I can do and I'll keep this question updated if I succesfully repair it.

3
  • This is at present just a diagnosis. The green check-mark means "this solved my problem". I assume that your problem hasn't been solved yet; if you remove the tick from your answer, other people will see that your problem hasn't been solved yet. You can always put it back on if you get the power supply working again, after your answer explains how you did it.
    – wizzwizz4
    Commented Sep 28, 2016 at 18:20
  • @wizzwizz4 You're right, I'll keep this question "unanswer" as long as I haven't fixed it. Thanks. Commented Sep 28, 2016 at 18:39
  • You may see if there is a hacker/maker space near you, those usually have people who can teach you the required skill. It isn't difficult and power supply circuit boards are usually not multi-layer main boards. Commented Feb 13, 2017 at 21:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .