4GB Compact Flash KS 3.1 40.68 WB3.1 Latest WinUAE

I just created a Compact Flash (compatible Transcend) partitions under Workbench on latest WinUAE using this guide. Despite following the steps my CF doesn't show up in WB, therefore I cannot format partition.

I can format it to Windows and use it alright. But each time I clean it in diskpart and set partitions again under WinUAE it just doesn't show. I tried to mount it on IDE auto, UAEHF.DEVICE, SCSI. Still doesn't show up.

When I go to HDTools, however, it shows as one partition used not 2 or 3 I created. I don't have other card handy now, anyway to fix it before it arrives?


Did you try partitioning and formatting it on the Amiga instead, and then loading it into WinUAE?

That would create the correct Amiga RDB instead a DOS MBR bootblock.


CF has to be removed from Windows after partitioning and WinUAE completely closed and reopened once again with Admin rights.

  • well if you don't open winuae in admin mode it's impossible to use harddisks or CF cards. You can't even select them in the UI Aug 7 '20 at 18:13
  • Ofcourse, otherwise I wouldn't be able to perform previous steps Aug 7 '20 at 19:21
  • you don't need admin rights anymore to read CF cards (to my surprise) May 14 '21 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.