2

I've picked up this CDTV some time ago, but didn't have DiagROM to test it properly. It is running perfectly fine, all features. My diag chip arrived this morning, and when I get to Extended Memory Test it completes with no bit/byte errors, but throws an IRQ error like this. EDIT: there are some errors?

Is it due to fact that CDTV has extended ROM, and access to CD at boot or there is something wrong with the machine? How to get started to decoding these error codes, if I want to learn?

I wanted to bring something up, as I just tried to fit in PiSTorm and had random address errors on buptest tool (it writes garbage to chip ram and reads it back). I replaced PiStorm with stock CPU and ran DiagROM again. What does it mean and what are these artifacts on the screen towards end of the test?

https://youtu.be/D58ws_-XFTI

3
  • "when I get to Extended Memory Test" - do you mean test 2 - Extended chipmemtest? – Bruce Abbott Jul 17 '20 at 23:49
  • Yes, sorry, I should be more specific – Bartek Malysz Jul 17 '20 at 23:51
  • 1
    It is a bug on 68000 machins. fixed in the "daily" 1.3 beta. – Chucky Apr 3 at 22:27
3

In the DiagROM "AddressError Detected" is displayed when the CPU enters exception vector #2 at address $0000000C. This occurs if a word or longword access is attempted at an odd address, which is illegal on the 68000 (but not 68020 and above).

Unfortunately the debug data doesn't include the PC or stack contents, so I can't tell what code caused this exception. However in the register dump we see that A0 contains an odd address $00F8E5A5. This points just past the end of the message "Checking full Chipmemarea until 2MB or Shadow-Memory is detected" in the ROM, presumably getting there after printing that message.

No other address register contains an odd value and there are no indexed instructions in the code, so it seems the program incorrectly tried to use A0 to read or write a word or longword value at the odd address.

You say that the memory test completes with no bit/byte errors, so it must be 'crashing' after getting to the end of the test. I have examined the code and can't see why it is doing this. I also compared the source code with the latest version (1.21) but could not see any relevant differences.

Since the memory test is passing and your CDTV works fine I wouldn't worry about the DiagROM error. It's probably just a minor bug being triggered by some difference between CDTV and other Amigas (as CDTV isn't mentioned in the source code or documentation I'm guessing the author of DiagROM doesn't have one to test it on).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.