1

So appearently there's a Red Hat Linux Enterprise 5.1 and I'd just like to make it clear that I'm not trying to install that. I'm trying to install the original Red Hat Linux 5.1 from 1998 in a virtual machine for use in a project.

I tried VirtualBox first, and during installation I got multiple errors regarding the architecture. Some google searches taught me that VirtualBox has trouble emulating Linux 2.1, and I would need to set up VirtualBox on a 32-bit system. I don't have a good enough 32-bit system to run VirtualBox, and I'd rather use my 64-bit system for the better monitor and specs anyways.

So I tried QEMU. After a three hour journey that consumed my night, I have concluded that while Red Hat does install in QEMU, X can only be used in the cierra VGA mode at 16 colors. Any other VGA mode and X throws an error lack of memory, even if I'm simply at 640x480 with with 16 colors. The cierra mode CAN use more then 16 colors, but doing so causes fonts to render poorly and the cursor to render invisible. I don't want to go into specifics, but for the project I will need at least 640x480 with more then 16 colors.

What is the best way, then, to emulate Red Hat Linux 5.1 while getting more then 16 colors? Alternatively, how can I get RHL running in QEMU with more then 16 colors? I should also mention that running on real hardware is not an option. While I do have period-accurate machines that can run 5.1, I need to be able to take advantage of features from my modern PC (such as fast internet access, and not having to constantly use USB thumb drives or floppy disks) for this project to go successfully. If nothing else, is there at least another old version of Linux that will run the Enlightenment Window Manager that can be emulated in QEMU with more then 16 colors.

  • 4
    The VM does not "emulate Linux x.x", it emulates hardware. You therefore need to configure the VM to emulate hardware on which Linux x.x can run. That may or may not be possible, but it's a problem with modern software - the VM implementation. – another-dave Jul 26 at 13:33
  • I am really surprised QEMU with -vga std doesn't work with the X vesa driver (xorg.conf necessary). I don't know where the out of memory comes from (you didn't include any actual error messages), but I'd guess I'd classify that as a bug in QEMU, and try to fix it. – dirkt Jul 26 at 15:06
  • And you can increase framebuffer memory as in -device VGA,vgamem_mb=32 etc., if that is the problem. – dirkt Jul 26 at 15:07
  • Sounds like it's working perfectly. I seem to recall that xfree86 had problems back in the day so I used Metro X instead (I think there was a demo version or light version on the RH CD). – Kelvin Sherlock Jul 26 at 23:52
  • I actually ended up giving up and I'm installing AntiX right now. @KelvinSherlock – ioi-xd Jul 27 at 2:36

Browse other questions tagged or ask your own question.