5

I used to have an old Toshiba T2000SX laptop, but some day its HDD died. I found a newer laptop HDD that fit in and I could format it to appear to have a small enough capacity to get detected by the laptop.

However, I could not boot from this disk, although reading and writing to it worked like a charm. Installing DOS and even Win 3.11 went well, I just had to always boot from a boot floppy disk that then loaded the system on the HDD.

When I tried to boot directly from the HDD, the screen filled with rows of 02 sequences that then started to continuously move to the left (if I remember correctly) as soon as the screen was full. No reactions any more, need to hard-reset.

So I guessed Toshiba has built some kind of protection into the chipset that prevents booting from non-Toshiba HDDs. I continued occasionally using it by booting from a floppy, but when the floppy drive later died as well, I abandoned the entire laptop.

Out of pure curiosity, was this "error 02" really a protection against foreign HDDs or would it have had a different cause? Were such protection mechanisms common back in this laptop's time?

  • It's too bad the floppy drive is dead, because you could try running the diagnostics program mentioned in the service manual to see if that narrows it down. – user12 Apr 21 '16 at 16:38
  • What size and block size is the "newer laptop drive"? There have been many size ceilings in IDE history... a drive over 8GB can crash some late 1990s (!!!) BIOSes, so definitely avoid that in an even older machine. Even a drive >504MB could be trouble, ESPECIALLY if it has been formatted/partitioned on a more modern machine. – rackandboneman Aug 17 '17 at 9:27
  • To save others the research effort: Yes, these drives were early IDE, not a custom ST-506 interface variant.... – rackandboneman Aug 17 '17 at 9:37
6

Error 0x02 is "Bad Address Mark" (Don't ask me what this actually means!)

I don't think Toshiba specifically forbid third-party drives, but it probably expects very specific IDE drives of specific geometry. According to the internet, there are three specific Conner drives this model could ship with.

I assume you accessed the SETUP and made sure that the hard disk capacity was set properly?

This sounds like the BIOS can't find the location to start booting because the drive geometry is unexpected.

  • 1
    Yes, I think I did that. I reduced the visible capacity using jumpers or low level formatting (or both, not sure any more) and the HDD could get correctly accessed, I installed an OS and stored data on it without problems, just the booting does not work. – Byte Commander Apr 22 '16 at 5:46
  • Hmmm. That might be the problem. Because I don't think the "soft" vs. controller geometry will match, and some IDE adapters really didn't like that in the old days. I bet it's failing really early in the boot process trying to find the right sector. To test this I suppose you could find out the geometry of the stock 60Mb Conner drive and use fdisk on a newer drive such that it reports the same geometry. The size probably doesn't matter, other than you won't see most of it. – user12 Apr 22 '16 at 13:49
  • Could be, your explanation sounds logical. I was around 12 years old when that happened, so I can't really tell further details or verify it any more... Thanks for your insights though. – Byte Commander Apr 22 '16 at 13:52
3

It is a problem with the format of the disk: when a disk gets formatted, each track has more or less the same information to define a track (start, id, and some empty space called a gap) and sectors on them (sync, sector id, data mark, gap, etc).

When you get an error 02, the Bad Address Mark, it means that once the read cycle has synced with the track, it won't find the id of the sector.

At this point there are 3 possibilities:

  • the disk is damaged
  • the Toshiba is expecting a very specific format
  • the geometry of the disk is not set properly

Most likely it is the last one; and, if not, you may need to boot from a floppy to format the disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.