4

Some weeks ago I got a non-working Powerbook 145b for 20€ (~23USD). The first thing I did was to test the power supply, which was giving a good 7.8V.

I saw that the battery was still in place and I feared the worst. When I took it out my suspicions were confirmed: corrosion.

corroded battery

It was looking pretty bad and it didn't look any better when I opened the laptop:

enter image description here

I spent quite some time cleaning everything and given my experience with a Powerbook 180 (which had broken traces underneath the battery connector) the first thing that I did to start troubleshooting the main board was to desolder the battery connector.

I could see how the trace that goes from one of the battery connectors to the fuse was completely gone. I fixed it (red circle in the image below)

After some more checking, I also saw that the trace going from R99 to the third pin in the connector, which I think is for the battery temperature sensor, was broken. I ran a wire from the resistor to the back pin of the connector (in blue in the image below). Not sure if this one was critical for the board to work, given that it is for the temperature sensor connector, but well... it is fixed also.

enter image description here

I couldn't see anything else, but the laptop was not working yet. I put more time on checking and cleaning, I saw that the buttons (startup and reset/interrupt) were not working properly, so I cleaned them thoroughly. And finally, the laptop turned on!

I used it for a bit and there were some things not working, like the mouse (which I also troubleshot later and saw that one of the diodes is gone). But the seller also sent me one of those old Apple mice so I was able to use it.

The next day I went to power it on again but it was not working. I could hear some weird sounds through the speaker. I started moving the power adapter connector and pressing the buttons at the back. I desolder the buttons and the battery connector from the board and cleaned them, also tested and they were fine. So I put them back and still the same. I also replaced the PRAM battery. After much more time testing and trying stuff I've been able to get the "trick" to start it up.

I need to press the reset button for a while (~10 seconds) one or two times and then it starts fine. Here is a video showing it

At this point, I have no idea what is the issue with the laptop.

Sorry about the long post, but I wanted to explain the whole process I've followed to get to where I'm right now.

Does anyone have any idea what is going on? or what else can I try?

Thanks

2

Startup is when the CMOS data is accessed; it's likely that you will need to reset PRAM (parameter random access memory, aka CMOS) by holding down command-option-P-R for several seconds after powering ON. There will be a beep to acknowledge the reset, usually one waits for the beep to repeat, then you can let go.

The backup battery for the CMOS is (if memory serves) a rechargeable lithium cell (similar to Panasonic VL2020), which after all this time may no longer accept a charge. You've replaced it (good) but it will still need a few hours of power-on before it charges. I hope the replacement IS the rechargeable type (it looks like a primary coin cell, but it is NOT the same electrically).

1
  • Thanks for the response and sorry for the long delay... I didn't have the laptop with me until now :/ From what I've seen here, the way to reset PRAM on the 145B is by pressing the reset and interrupt buttons, right? jacsoft.co.nz/Tech_Notes/PP_Manage.shtml Regarding the battery, I didn't find the exact same one, so I bought the Panasonic VL2330 -> ru.nkon.nl/panasonic-vl2330-1hfn.html – JV Lobo Dec 21 '20 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.