7

I am trying to install "Kid Pix Deluxe 4" on Mac OS 9 using SheepShaver on Ubuntu 16.04.

A problem I am having is that when I try to install it, I get an error saying that I don't have enough memory. So I made a hard disk file with 4.8 GB on it and added it to SheepShaver, but when I try to select it when I am installing Kid Pix, it gives me the same error, saying 'Not enough room on OS9 to install'

I am using the OS9 image and the New World PPC ROM from Redundant Robot.

5
  • 2
    Hey Jordan, did you create a new account by mistake? I've seen your other one here. You should mod flag for an account merger.
    – JAL
    Commented Nov 15, 2016 at 23:22
  • How much RAM is your virtual machine configured for?
    – Mark
    Commented Nov 16, 2016 at 0:01
  • I have it configured for 256MB of RAM Commented Nov 16, 2016 at 0:39
  • How much space is available on your hard drive and how much does Kid Pix Deluxe 4 need? Commented Nov 16, 2016 at 0:55
  • 1
    @JordanBaron I've found two duplicate accounts, with the help of the Mod tools. Are you this account (with lots of activity) and / or this account (with very little to none, but on the same IP)?
    – wizzwizz4
    Commented Nov 16, 2016 at 7:21

2 Answers 2

3

The message “Not enough room on OS9 to install” suggests that it's not a memory problem, but an (emulated) disk space problem. The installation image you downloaded is labelled OS9, which is a clue.

Classic Mac OSs can be a bit precious about where they install software, so maybe Kid Pix is trying to install on a small installation image. Can you enlarge the image, or install on a much larger emulated disk?

1
  • For that matter, the disk might be too large, and the installer is seeing 2GB free as -1 bytes free.
    – Mark
    Commented Feb 18, 2017 at 20:10
2

When it says, you've not enough memory, it is referring to RAM. For all of my virtual machines, I set the RAM to half of what is actually on my computer. I have a computer with 4GB of RAM. Even when I'm emulating Windows 3.1 and Tiny Core Linux, I use 2GB RAM for good measure. I suggest that if you use a computer for such, it should have at least 1GB of RAM.

11
  • aaa, do you have two accounts? Do you need them to be merged?
    – Matt Lacey
    Commented Nov 16, 2016 at 3:37
  • I think I might, but this is not a permanent account anyways. I'm not 14 yet so I'm unable to sign in via Yahoo! I'm just trying to help.
    – aaa
    Commented Nov 16, 2016 at 3:40
  • Ah it's listing you as unregistered. Are you under 13? You have to be 13 or older to register on the StackExchange network :(
    – Matt Lacey
    Commented Nov 16, 2016 at 3:46
  • I'm 13 but not 14 just yet. I do find my self fairly knowledgeable for my age.
    – aaa
    Commented Nov 16, 2016 at 3:47
  • 1
    So you probably can't register with Yahoo, but you could just create an account directly on StackExchange. If you do that we should be able to get your (so far) 2 accounts combined.
    – Matt Lacey
    Commented Nov 16, 2016 at 3:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .