2

Windows Management Instrumentation (WMI) was made available as a separate download for Windows NT 4.0 SP4 and above. I know that WMI installs and works great on Intel IA32 (x86) flavors of NT4, because I have the WMI redistributable and I've tested it.

However, Windows NT 4.0 Service Pack 4 (SP4), SP5, SP6, and SP6a were released for both the Intel IA32 (x86) and DEC Alpha architectures of Windows NT 4.

My question is: did Microsoft release a WMI redistributable for NT4 that worked on DEC Alpha?

I have a WMI redistributable for NT4 (wmint4.exe, SHA256: A958C28D19507784BC66D42404952D755281FF3549660605613C4EDD3E489809), but I do not have a DEC Alpha system to know if it would install there. I could also speculate that there may have been a separate download for DEC Alpha NT4 systems.

For completion sake, it is worth noting that Windows NT 4 was originally released for MIPS and PowerPC platforms, too, but Microsoft abandoned further development for these platforms before the release of SP4. Because the WMI redistributable required SP4, I can conclude that WMI could not be added to MIPS or PowerPC versions of NT4.

8
  • Going from memory, it seems like WMI was a separate download in the SP4/SP5 timeframe, but was included in SP6/SP6a (or possibly the post-SP6 security rollup). A quick look through some old references (e.g., flylib.com/books/en/4.84.1.71/1), seems to confirm that it was included in SP6. – Jerry Coffin Jan 23 at 20:23
  • Interesting. When I was testing NT4 on Intel IA-32 (x86), I installed NT4, then installed Service Pack 6a, then installed Internet Explorer 6. At that point, I ran a VBScript that used WMI, and it failed. Next, I installed WMI and then the script worked, so I assumed that WMI was not included in Service Pack 6a. – Frank Lesniak Jan 23 at 23:11
  • Well, it may not be--that web page/book could be mistaken (and it pretty much goes without saying that my 20+ year-old memories could very easily be wrong). – Jerry Coffin Jan 23 at 23:15
  • 1
    I'll check into that soon and report back; I have an ISO of SP6 already downloaded. I'm just waiting for my employer to issue me a license for VMware Workstation. – Frank Lesniak Jan 23 at 23:30
  • 1
    Aside: You could also use Oracle VirtualBox if you are not able to get a VMware Workstation license. – Bill_Stewart Jan 31 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.