5

I have a Commodore 1541-II drive. I bought this drive used (but like new) a year ago and I used it on my Commodore 64 for about 6 months, but I moved and just reconnected it to my Commodore and it no longer seems to work right. When trying to perform a directory (LOAD "$",8), the screen is just stuck showing "Searching for $". I have confirmed the dip switches are set for channel 8 and confirmed the Commodore and serial cable work by testing them on a Commodore 1571.

What's puzzling is I also have a Commodore 1581 that is doing the exact same thing. It worked about 1 year ago, and now is just stuck showing "Searching for $", but this one has a red blinking power light. Both were working fine, and have been kept in a temperature controlled room before reconnecting them.

The only thing I can think of that may have possibly damaged them (if they are in fact damaged), is I may have configured the dip switches to work on a channel that is already in use by another drive/device on the serial bus. However, I assume that wouldn't fry any of the circuits, but it's the only thing I can think of.

The other remote possibility is that I connected both of these drives to my Mega65 DevKit. By tinkering with the channels trying to get them to show up on the DevKit, these drives may have been damaged, but again, I believe this to be highly unlikely.

So I'm left puzzled with how both of these drives could have stopped working at the same time.

I figured I start by troubleshooting the 1541-II first. Does anyone know how I might be able to get my 1541-II working again?

Here's a short video of what I'm seeing:

https://www.icloud.com/sharedalbum/?fbclid=IwAR2cMiPbISJ5CduzDVh22NLzfftH7ex2CVhoNCF8PCzg3yu4U8wzbqLa304#B0gGWZuqDGXCs5P;0102F093-C3C9-4501-9360-C016CE9F0A78

Since posting this, the 1541-II new behavior is when powered on, the red and green light stay on constantly, and never go off. The motor runs constantly. Any commands I issue to device 8 (where the 1541-II is configured) result in no output after submitting the command. I tried to issue the following, but nothing happened:

This was one of the commands from Ray Carlsen's guide:

OPEN15,8,15:PRINT#15,"I0":CLOSE15

And from the same guide:

10 OPEN 15,8,15 
20 INPUT#15,EN,EM$,ET,ES 
30 PRINT EN,EM$,ET,ES 
40 CLOSE 15
RUN

The result of both of these was the green and red light still stayed on and the motor kept running. Screen didn't return.

1
1

(This is not a complete answer as the solution space is still rather open from what you describe. If more details narrow it down, I'll update this.)

The fact that you have multiple drives failing after connecting them to a 3rd party kit inevitably directs attention in that direction. It is possible to damage the IEC bus from external sources, in which case it is likely the 6522 VIA (U6) or any glue logic in front of that (i.e. U7, U9, U11) has suffered. I'd probably focus on back tracking through the circuit from the serial connector.

Alternatively, it could also indicate that those drives are not the issue, but the C64 itself is. But as you already confirmed in comments that the C64 is working with other devices, we can rule that angle out.

It is clear from the sound on your video that something goes wrong the second you turn on the C64, the motor keeps spinning. (By the way, never turn on the drive with a disk inserted like that!) The drive should reset but could be stuck in reset.

To rule that out, connect the drive and probe the reset signal as it arrives on the CPU or VIA. If it's asserted here, U14, U7 or U1 could be damaged.

There are other failure modes than stuck reset that leads to the motor spinning continuously, Ray Carlsen gives a good overview here. The gate driver (U13) could be a suspect, the ROM or even the CPU, although I think the odds of both drives failing identically on any of these are low. Focus on U7, U9, U11 and ultimately U6.

Connecting two devices with the same device number should do no damage as the bus signals are open collector.

For what it's worth: it is very likely that the drive is repairable, but you will need basic electronics equipment and knowledge to carry out the fault finding/repair yourself.

2
  • I've confirmed the Commodore 64 works with a 1571 (using the same serial cable) and SD2IEC. Unfortunately, I don't currently have the means to probe chips or cables. I'd have to order a probe, I guess? Jun 21 at 16:52
  • 1
    You can get some way with a cheap multimeter, probing voltage levels. You will probably have to swap some ICs and I believe that in general they are not socketed on these boards. Most are through hole so serviceable with a decent soldering iron, a solder sucker, some solder braid and some patience. Practice on some scrap board first, if you never did this before (and dive into some of the many YouTube videos on the topic). Never too late to start developing basic soldering skills, it is quite useful to be able to do when around old computers. :)
    – Retrograde
    Jun 21 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.