I have Commodore PC 30-III 286 machine with a serial port at the back labelled "mouse". If I plug my Commodore mouse 1900 serial mouse then execute mouse.com at the DOS prompt then I get the following message:

Driver not installed - Microsoft mouse not found

Strictly speaking it is correct, because it isn't a Microsoft mouse. What should I do to use the mouse?

Commodore Mouse 1900


After enabling COM ports in BIOS the machine starts up like this:

PhoenixVIEW(tm) VGA-Compatible BIOS Version B 1.00 07
Copyright (C) 1984-1990 Phoenix Technologies Ltd.
All Rights Reserved

│ Commodore 286 BIOS  Rev. 2.01               390339 - 03     │
│                                             390340 - 03     │
│ Copyright (C) 1988 by Commodore Electronics Ltd.            │
│                    All Rights Reserved.                     │

Onboard   Mouse   at 023C
Onboard   Com     at 02F8
Onboard   Lpt     at 0278
Starting MS-DOS...


and the Commodore mouse.com and comtest.com display this:

COMTEST v2.6 (030301) - Utility to detect serial ports
Copyright (c) 2000-2003 by Arkady V.Belousov, licensed under GPL2

COM# Addr IRQ# Type                      Attached
---- ---- ---- ------------------------- ---------------------------
  1  02F8   3  8250A/16450 (no FIFO)
  2  0000      not found
  3  0000      not found
  4  0000      not found
Tulip (R) Computers Mouse Driver, Version 7.04c
Copyright (c) Tulip Computers, 1991
All Rights Reserved.

Bus mouse driver installed on IRQ 2.



When I connect an amiga tank mouse and execute mouse.com then the button clicks are recognized, but the cursor still doesn't move

  • 8
    There are several different ways to speak mouse. The driver does not correspond to the hardware, so find one that do. Commented Sep 21, 2021 at 13:39
  • 2
    Put CuteMouse on and see what it finds. cutemouse.sourceforge.net
    – Alan B
    Commented Sep 21, 2021 at 13:59
  • 3
    That looks like a Commodore Basic Mouse III (Model 1900), which should support both Microsoft and Mouse Systems serial protocols. It is unclear how the mode change is done if there is no switch on the mouse. If it is set to Mouse Systems mode, it will need a driver that supports it (e.g. CuteMouse). Of course, assuming that the port on the 286 is a RS232 serial port and it works properly.
    – Justme
    Commented Sep 21, 2021 at 20:12
  • 2
    Beyond having the right driver, you might have to check the serial port is setup correctly. I don't have firsthand experience with 286 generation hardware, but 386/486 systems need the serial port IRQ and address configured correctly (usually via jumpers on the Multi-IO card or motherboard).
    – Geo...
    Commented Sep 21, 2021 at 22:43
  • 3
    Is it a Commodore manufactured 286 PC? The answer to your question could be quite different depending on if it is or if it's a standard PC.
    – mnem
    Commented Sep 22, 2021 at 1:56

5 Answers 5


Since your mouse has three buttons, it won’t use the same protocol as Microsoft mice (at least, in three-button mode), and won’t be fully supported by the Microsoft driver.

Presumably the mouse was originally provided with a suitable driver; if you can find that, it should work. Alternatively, you can try CuteMouse, which is a DOS mouse driver with support for a variety of serial mouse protocols. It includes a mouse test tool which you can use to check that your mouse is detected and supported correctly.

Your latest screenshots suggest that the mouse is configured as a bus mouse, not a serial mouse. The system appears to configure the mouse port at 0x023C, presumably on IRQ 4, and the serial port at 0x02F8 on IRQ 3 (which matches the typical assignments for COM2); so CuteMouse’s comtest program only sees the latter, and doesn’t actually test the mouse port. I would have expected a round, DIN-style port for a bus mouse, but the 0x023C address is the address used for bus mice. With the Microsoft driver, try mouse /b to load the driver for a bus mouse.

  • Thanks I tried cutemouse it says device not found. If I run comtest.com that is bundled with cutemouse then it says not found for com1-4. I downloaded a commodore mouse driver from here archive.org/details/commousev411 and it also says that no COM ports are available. Commented Sep 22, 2021 at 7:25
  • 2
    comtest failing to find your serial ports suggests that that’s where the problem lies — even if the mouse isn’t working, comtest should find the UART driving the serial port. Are there serial (or mouse) port configuration options in the BIOS setup? Do you have a spare serial card you could try? Commented Sep 22, 2021 at 7:37
  • I just managed to get into the BIOS and yes the mouse and com ports were disabled. I enabled them and now mouse.com and the commodore mouse test both runs. The mouse cursor appears and.... nothing happens, the mouse cursor not moving. I am not sure if this is a hardware failure, or still a software issue Commented Sep 22, 2021 at 10:05
  • Do the buttons work? If the Commodore test program doesn’t show that, CuteMouse’s mousetst will. Commented Sep 22, 2021 at 10:20
  • neither cutemouse, nor commodore mouse test shows anything. I see no difference when I plug in the mouse or not. If I call mouse.com it says it installed itself. If I run imouse.com from commodore it says no com port found. If I run mouse.com from commodore it says it installed itself. Regarless of which one I run neither the buttons, nor the movement is working Commented Sep 22, 2021 at 11:08

Since it is a Commodore PC 30-III, the mouse port is not a serial port and no serial mice should be plugged into it.

The mouse port is only compatible with Commodore mice that send the quadrature signals directly, i.e. so called bus mice.

If you want to plug in a serial mouse, you must use the only serial port with the DB-25 connector.

  • To be more specific it uses the same protocol as the Amiga mice do. The PC sees it as a normal Microsoft Bus mouse so the MOUSE.COM driver should just work with it in DOS when a proper Amiga mouse is used.
    – mnem
    Commented Sep 22, 2021 at 19:29
  • 3
    Thanks for the tip, I connected an amiga tank mouse, executed mouse.com and mouse test can finally detects left and right click, but the cursor still doesn't move. Commented Sep 22, 2021 at 20:05
  • 1
    That is a good start. Then you need to determine if the problem is with the mouse or the PC. Technically, if the mouse works fine on an Amiga, it means that the PC mouse port is not working. Maybe someone else has plugged in a RS232 device (modem, computer) and it can be damaged. Unfortunately, I could not find schematics for your PC model.
    – Justme
    Commented Sep 23, 2021 at 9:06
  • The mouse works with my amiga so the mouse port might be faulty? (I hope not) I found a description of the mouse port of a PC 10 - III . I assume it is the same as for the PC 30 - III. See the page 16 of zimmers.net/anonftp/pub/cbm-pc/schematics/… . It shows that certain pins are responsible for the movement, but can it be that all the movement pins went wrong at once? Commented Sep 23, 2021 at 13:09

In the age of serial mice, there were two completely incompatible standards that most mice emulated (many had a physical switch to select either of both, eg the popular Genius brand mice) - "Microsoft" and "Mouse Systems". A 3 button mouse without a switch is very likely "Mouse Systems" and needs a driver compatible with that protocol, since the original "Microsoft" protocol did not support 3 buttons.


To answer my own question I ended up buying a converter from 25 pin serial to 9 pin converter like this :

enter image description here

With that I could connect my mouse to the serial port. After I enabled the serial port in BIOS the mouse works perfectly using the standard mouse.com


Port 023C sounds like it could be compatible with a Microsoft InPort bus mouse. Try a MS mouse driver for DOS (version 8.20 or older) with parameter /I1 or /I2.

  • I tried both mouse /I1 and mouse /i2 and it said mouse not found. If I call mouse without parameters it says mouse found, but it doesn't work Commented Sep 22, 2021 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .