5

Today I tried out an old M2 for the first time with an USB/P2 adapter. For the first 10 minutes it worked fine. Then I set it aside on my desk, left the room for a second, came back and suddenly the caps lock and scroll lock lamps were on and not a single key reacts anymore. Nothing has fallen onto the keyboard and the keys are not stuck. I already replugged the board and restarted the computer, and the two lamps went back on immediately.

I run Fedora Linux on a mid-2011 Mac mini and would be thankful for any advice.

  • Welcome to Retrocomputing Stack Exchange. Thanks for the question; this is quite a surprising problem. You might want to read the tour and have a look at some other questions to get familiar with the site; you might be able to answer some of them. – wizzwizz4 Jan 29 '17 at 16:17
3

It's probable that the capacitors on the controller PCB have failed -- this seems to be a common fault with M2 keyboards.

There are various pages that walk through how to replace them, for example this one. There are two capacitors to replace: one is 2.2uF 50v and the other is 47uF 16v.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.