I bought a Compaq LTE 5100 that came without a drive. I got a replacement caddy from an Armada and the drive is recognized in BIOS (60GB drive, listed as 8GB as expected).

What I have:

  • a stack of floppies
  • external floppy drive
  • IDE to USB adapter
  • a WinXP SP2 laptop (Dell)
  • Win98 SE boot floppy image
  • Win98 SE installation CD image

I don't have a USB PCMCIA card yet so I can't use CDROM with the Compaq.

What I did:

  1. delete partitions from IDE drive with fdisk from Win98 floppy
  2. recreate active 8GB primary partition
  3. plug the drive into the Dell
  4. It demands formatting, so I format it as Fat32 with DOS boot files and copy over Win98 setup
  5. reboot Dell from the IDE drive and run Win98 Setup seemingly successfully
  6. reboot as required, "invalid system disk" appears, presumably because it's not bootable? (same error if I copy over the DOS boot files from the boot floppy but I didn't expect that to work)
  7. plug it into the Compaq for good measure, "disk I/O error, replace disk" - I assume this is basically the same error? Or could this mean that while the drive caddy seems to work, it's actually faulty?

For the record, CHKDSK can't find any issues with the IDE drive.

Does anyone have some ideas? that USB card will arrive in the mail eventually but I hoped to make progress on this this weekend...

Alright, so I ran fdisk on the drive to create a new primary partition, this worked fine. It requested a reboot but I had to pull the plug because this laptop won't let me get back to A:.

Now I tried to boot from the diskette again but found that format is not actually on there - copied it over from the Win98 boot CD.

Next issue: The laptop cannot boot from floppy while the HDD is connected (It just freezes on "booting from floppy"), so I have to boot and connect the drive after. The drive is not detected now though, so I can't format it. Any idea how to evade that?

I guess I can try to do this stuff in a Windows 98 VM...

PS: The laptop won't try to boot into anything until I loaded the BIOS once, hit "save & exit" and then ignore the BIOS prompt. Maybe that's all related... I can't imagine that being normal.

Regarding the issue, to clarify the drive issues: round 1:

  • I disconnect the HDD
  • boot the floppy
  • A:> prompt appears
  • I connect the HDD
  • I can run fdisk on the HDD
  • reboot prompt
  • unplug laptop to restart

round 2:

  • I leave the HDD connected
  • try to boot the floppy but it freezes
  • unplug the laptop
  • disconnect HDD
  • now boot from floppy
  • A:> appears
  • I connect the HDD
  • format can't find a drive when I try to run "format c: /s"

Regarding Ontrack & EZ-Drive: Ontrack won't write floppies, insists that I need to close the write protection hole (open or closed makes no difference)

EZ-Drive: I can start ez.exe, start the process but when it asks for a DOS system disk (I used Disk 1 & 2 of MS DOS 6.22) it tells me it can't read a sector on A: and fails. I tried three of my four working floppies for this. I write the images onto the disks with "rawwritewin" which seemed to work perfectly fine for the EZ-Drive floppy.

During my last attempt EZ-Drive couldn't find the HDD at all. I'll try to figure out how to evade that tomorrow.

  • 3
    I suspect a hard drive geometry mismatch somewhere. It’s almost bound to happen when a disk is formatted or partitioned on a different machine from where it’s supposed to be used (especially when adapters are involved). For best results, you should (a) partition and format the disk on the target machine, (b) temporarily connect the disk to another machine to copy the installer files, then (c) reconnect the disk to the target machine to run the installer. Otherwise you’re (very probably) going to have a bad time. Nov 19, 2021 at 19:03
  • 2
    Does this answer your question? Booting from SD card on a Compaq LTE 4/75 – DOS 6 works, Windows 95 doesn't
    – Brian H
    Nov 19, 2021 at 19:18
  • I mean, that explains what's going on (I assume this is exactly what's wrong) and I think I simply misunderstood what fdisk does, hence the whole "Windows XP demands a reformat" issue... yeah... I think I just created the partition but didn't format it lol. That seems like.. a very basic error. Lets try it again with the target machine. Thank you both!
    – Retronoob
    Nov 20, 2021 at 19:03
  • 2
    @Retronoob You might want to merge your accounts, retrocomputing.stackexchange.com/users/23412/retronoob, retrocomputing.stackexchange.com/users/23416/retronoob and retrocomputing.stackexchange.com/users/23417/retronoob. Please use the contact form at the bottom of the page to request this; then you'll be able to comment on and edit your questions properly. (Also, please only use the answer box for answers; see How to Answer and the tour for details.)
    – wizzwizz4
    Nov 20, 2021 at 21:06
  • 1
    You should definitely not connect a hard disk to a running computer. ATA is very much not a hotplug bus. If you cannot boot while the drive is plugged in, that’s the problem you need to solve first. Nov 23, 2021 at 8:11

2 Answers 2


I have a Compaq LTE 5150, which is very similar to the kit you have.

  1. You won't be able to boot it with a hard disk larger than 8 GB, at least I have never been successful. Even using On-Track, it would lock up instantly at "Starting MS-DOS" or "Starting Windows 95". Those were 2 GB FAT 16 partitions, on a 16 GB CF using CF-to-IDE, so the size of the partition doesn't really matter. It works fine using a 4 GB CF card. I'm wondering if that is why you are running into the freezing on booting the floppy disk. (The floppy drive for my LTE died years ago, so I am unable to test.)

  2. Regarding the BIOS prompt stuff: That is likely because the CMOS checksum is invalid because the backup battery is long-dead. The BIOS is hard-wired to require you to start Computer Setup once when the checksum is detected as invalid. I want to say that pressing F1 then F2 may allow you to skip it, but it has been years.

P.S.: I followed a very similar path to you for initial installation since my LTE can't boot from CD. It should work fine.

  • 1
    I tried to install MS-DOS instead of 98 to try and get a properly formatted drive, and yeah, it locked up right at "Starting MS-DOS". I guess this is the reason none of this works. Thank you! I'll get an 8GB drive and try again.
    – Retronoob
    Nov 28, 2021 at 11:00

I haven't installed Windows 98 for a long time but if my memory serves well:

  1. Use EZ-Drive and reformat your HDD (IIRC you can use 40GB safely; ideally, if your drive has a switch for 40GB limit, use it)

  2. Create 2 logical drives: one will be your system and second will be used for the installation (just copy the CD-ROM files onto it)

  3. Boot your Windows 98 boot floppy

  4. Run Windows 98 setup from your HDD drive

Installing Windows 9x from HDD and leaving the install files there will spare you a lot of clicking when reinstalling drivers and/or any localization or other stuff ...

  • 1
    ...or Ontrack Disk Manager.
    – ssokolow
    Nov 20, 2021 at 17:51
  • I tried to do this but could not find the HDD - maybe there's a lack of understanding on my part about how this works but the floppy drive A: showed the files on the boot floppy as expected, but there was no HDD under C: or anywhere else for that matter so I couldn't get to the setup files on the HDD. Probably the geometry issue mentioned above.. I'll go through it with your steps after proper formatting. Thank you!
    – Retronoob
    Nov 20, 2021 at 19:01
  • @Retronoob the drive must be formatted with FAT32 !!! and the boot floppy must contain FAT32 drivers (the W98 boot disk has them natively). The Ez-Drive gets around the geometry/BIOS limitations using LBA but you have to install it onto HDD boot sector (using the boot floppy of EZ drive or any other tool like that)... so first use EZ drive floppy, then boot MS-DOS from W98 floppy and use fdisk to create patritions ... then copy installation files (for example in different PC) ... then boot from W98 floppy again and run w98 setup. In case Ez drive boot is corrupted durring installation
    – Spektre
    Nov 20, 2021 at 20:05
  • of w98 use the EZ floppy again to restore it... You can check it IIRC durring restart EZ drive writes some message onto the screen durring boot...
    – Spektre
    Nov 20, 2021 at 20:08
  • I thought EZ-Drive is just another tool to format a drive so I tried the floppy first. I'll look at that. I'm starting to think I'm using the wrong windows 98 install media here though, with the whole format executable being missing and the version WITH format not fitting on my 1.44MB floppies. ugh.
    – Retronoob
    Nov 20, 2021 at 20:34

Not the answer you're looking for? Browse other questions tagged .