5

I have a Compaq LTE 5150 laptop from 1995 on which I've installed Windows 3.1. It runs fine, and I'm able to use the computer for Word, Lotus Organiser, etc with no issue for a period of time and then it locks up hard. It seems to last about 1-2 hours.

Once it locks up, it is completely dead. Powering off and then restarting yields CPU fan noise but a black screen. The small status LCD has all status indicators lit (which is what happens during POST) and never changes. If I leave the computer off for a few days, I can run another few hours before the process starts again.

I haven't tried an alternative OS yet, but I can't imagine Windows 3.1 - one of the OSes offered by Compaq when the system was new - causing a hardware fault such as this one. What would cause this issue? What is the best way to diagnose the issue? I have a multimeter but I don't have any other sorts of electronics equipment. I'm not sure if the local university would allow me use of their tools due to pandemic protocols.

7
  • 2
    That is an old machine. Running it, especially the original power supply (if that's what you use), is a real hazard -- put both on fire proof surfaces, don't leave unattended. Try a new power supply if you aren't already also to fix the problem. Btw, I suppose you can run 3.1 in a virtual machine of some kind these days. Here is an example, apparently. You should be able to use the original disk image. Nov 21, 2021 at 12:59
  • as they say, "Past performance, isnt indicative of future performance." Things work until they dont. Finding out why is the hard part.
    – Keltari
    Nov 21, 2021 at 15:24
  • Something similar happened to my computer (which was not an old model) several years ago, and the reason was because the graphics card was failing. One technician diagnosed it by running a stress test on the GPU.
    – Allure
    Nov 22, 2021 at 2:32
  • @Peter-ReinstateMonica I don't have the battery inserted at any time considering age. Is there any other reason you would consider this laptop to be such a fire hazard? My enjoyment of retrocomputing is mostly from running software on period-correct hardware, so virtual machines don't interest me except where hardware is infeasible to attain.
    – A. Wilcox
    Nov 22, 2021 at 4:44
  • 1
    @A.Wilcox The battery is surely the main risk. But old power supplies can blow up (a desktop one did that on me). For the laptop proper, I had no specific risk in mind beyond running old circuits. Oh, and I totally get your joy of running old stuff :-). Nov 22, 2021 at 6:28

1 Answer 1

15

Unfortunately, the reason for random freezes can be hard to identify as a lot of different failure modes can lead to this outcome.

Try to get hold of a bootable burn-in test program that works with a machine of this vintage that will put predictable and repeatable pressure on the CPU, RAM and I/O and see if there is any pattern in it triggering freezes. Fx about the same time into the test, always when I/O load is heavy, always in upper part of RAM test, etc. (Testing outside Windows this way will also help rule out it is some software failure for situations where the failure only lasts to the next reboot.)

"Works for a while" failures are sometimes due to cracked solder joints that conduct adequately for a while but stop to do so when the board changes temperature due to materials expanding or contracting. It can be hard to spot but sometimes visible in a visual inspection with a magnifier. A cold spray can be used to see if the board starts working again if cooled down or if certain areas of the board is cooled down.

It could also be that cooling is just no longer sufficient due to build-up of dust in fan and/or vents, or disintegrating heatsink compound so thermal transfer is reduced for hot components.

Crashes can also be due do damaged/marginal components that are no longer in spec, or that are overheating due to internal damage.

Excessive ripple on the supply lines can also lead to instable operation, but hard to measure without a decent oscilloscope. But electrolytic capacitors are always suspect in any aged electronics and bad ones can sometimes be identified in visual inspection (bulging/domed or having leaked electrolyte onto the board).

So, a lot of different things might be wrong and consequently the advice can only be general. Try to form a hypothesis (such as "the RAM might be bad") and think of a way to corroborate or invalidate it (such as swapping with known good RAM), then move on the next hypothesis, rinse, repeat.

Given the fact that the failure seems to last beyond a single reboot, the first hypotheses to test should probably focus on what might "fix" things after a while. Here temperature-related (incl. bad joints) is an obvious starting point. (But another could be some bad state kept alive by residual capacitor charge that slowly drains off.)

4
  • 5
    Electrolyte capacitors are a common point of failure for old electronics, that would be my first place to look. Not sure whether it fits the specific failure description though (can't restart immediately). Nov 21, 2021 at 13:04
  • 2
    I had a friend of mine with an Atari ST that had the PSU shielding doing a short when it would expand with heat :D that was a funny one to troubleshoot since it behaved normally when open
    – Thomas
    Nov 21, 2021 at 14:43
  • 2
    Electrolytic capacitors usually have the opposite effect, getting better as they warm up. Nov 21, 2021 at 21:28
  • 1
    The final point "residual capacitor charge" also applies to floating CMOS inputs. If a trace to an input pin is broken so the pin is not connected to anything, the input is affected by leakage current only. This current is low enough that it can take a lot of time for level changes even though the input capacitance is just some pF. Nov 22, 2021 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.