6

First I'd like to ask: Does anybody even know of this laptop? I was surprised to find 0 information about it online. I've was asked to see if I could get this thing to boot, but it was in rough shape. The battery had exploded and the HDD seems to be totally dead.

At this point I can get it to beep twice, but due to the lack of information I'm not really sure what the code means. Maybe it's because the hard drive is missing? I do have a bootable floppy in the drive and the floppy briefly reads it during the POST it seems. If it's any help the processor is an AM386.

The laptop in question

  • 2
    Do you see anything on the screen when you power up? It should show something. – snips-n-snails Feb 22 '17 at 23:59
  • 1
    Make sure you turn up the contrast if you're looking for something on the screen. – Greg Hewgill Feb 23 '17 at 0:02
  • @traal The screen lights up, but it doesn't display anything. – SimplySerenity Feb 23 '17 at 2:51
  • @GregHewgill I adjusted the contrast but I didn't quite see anything. – SimplySerenity Feb 23 '17 at 3:13
  • 1
    @RichF originally it did have a model number, but when searching for it the only thing I was able to find were replacement batteries. Unfortunately I don't know what that number was, and I think the label was accidentally thrown away. I can tell you though that Acculite is the model, and Accutron was the brand. – SimplySerenity Feb 23 '17 at 5:54
7

AFAIK, BIOS has always allowed booting from floppy. I can't imagine why any manufacturer would override that possibility. IIRC, the default boot order in the 386 era was A, B, and then C. Some BIOSs had settings that let you override that, and boot from C immediately without annoying floppy drive noise as it (they) tried to access a floppy. The reason for the default was for debugging. You might have good reason to not access the HDD first.

The point to all that is that there is apparently a problem with the floppy as well. Whether that is the floppy itself or the drive mechanism, I don't know. Do you know your bootable floppy is correct for that machine? For example, if the floppy were 720k double-sided and the mechanism only reads 360k single-sided, it may not be able to hande it. (Maybe it could, not sure. The point is there could be a mismatch, double-density vs single-density for example.)

  • It's possible that could be the problem, they are high density 3.5 inch floppies. My guess is that the laptop was made in 91' though, so it shouldn't be a problem right? Maybe the floppy reader itself is broken? I don't know what a broken floppy reader sounds like. – SimplySerenity Feb 23 '17 at 3:17
  • 1
    @SimplySerenity I don't know that there is a sound for a bad floppy drive. If nothing at all is coming up on the screen there is another problem. I would expect something to show up on screen, such as No boot device available. Your question mentions POST and a double beep, but I gather you've never been able to see any output to screen? You should also be able to get into a POST debug with F8 or some other key right away (different manufacturers used different keys 😐 ). But if nothing comes up on the screen, you'll have to address that first. – RichF Feb 23 '17 at 5:25
  • Good point. I did try connecting to the VGA out, but still no output there either. Do machines of this age not output to VGA until after POST? – SimplySerenity Feb 23 '17 at 5:58
1

The 2 beep post is likely the issue, what it means will depend on whose bios it has, pheonix and ami were the popular ones. You should find it on a chip.

Booting from floppy was always available if a floppy Drive was attached. You'll need a Dos 622 boot floppy at a minimum. A 386 era machine will support 1.44 floppies. If the system isn't completing POST you wont get that far.

Also based on the picture you do not have the brightness and contrast settings in the proper locations to see the screen. The right slider needs to be full right for full brightness. The contrast slider on the left will want to be between 25% 75% as a starting point, start with 60%. This era system had a non-Active LCD. It might be green, brown or white.

  • Two beeps could be an AMI BIOS "parity circuit error" code, or an IBM BIOS "POST error, review screen for details" code. Dell also uses a two-beep code, for "memory not detected", but I don't think Dell ever provided OEM parts. Phoenix and Award both use fancier beep patterns. – Mark Feb 24 '17 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.