2

I'm using an AST Premium Exec 386SX/20 laptop. I have installed a new BIOS battery and it does retain settings when the machine is power-cycled.

I'm attempting to install MS-DOS 6.22 from a set of 3 floppy disks, onto an SD-Card to IDE adapter.

MS-DOS disks 1 and 2 progress just fine, but when the installation gets to 99% completion I get an error message from the installer software saying that there was a read/write error while accessing drive "C" (the modern SD-Card hard disk adapter).

According to the on-screen information at the time of the error, it is trying to install the file "COMMAND.COM" to the hard disk. While doing so, the floppy drive goes quiet for about 15 seconds and then the error message appears. I get the option to retry the operation (have tried that several times to no avail).

I believe the floppy disks contain valid data, I used md5sum (under Linux) to compare the written contents to the original binary images and they match.

It seems like the floppy disks and the floppy drive are working OK, but the laptop's BIOS is not correctly configured for this modern hard drive adapter. The SD Card I have used is a generic 4GB one which is known to be good (it has spent a few years in my digital camera and works well).

In the BIOS, the "Auto" mode fails to understand the geometry of this SD-Card adapter, so I have tried manually setting it to mode 98 and 99, with various settings for "[Cyls, Heads, Sects, PreComp]". Respectively: [1024, 16, 31, NONE] worked as far as 99% of the DOS installer, but fell at the last hurdle.

I realise that the full capacity of the 4GB SD-Card will not be available, but that's fine, I'd be happy with 64MB or more, just to get the machine running a basic DOS system.

How do I configure this laptop to correctly handle this SD-Card adapter?

The chip on the SD/IDE adapter is an "FC1307A", but I cannot find any useful information about this chip's presented geometry. I've had slightly more luck with [512, 16, 31, NONE] - basically fdisk can at least attempt to guess it's size but it's still wrong.

New info:

Earlier today I managed to cd onto the C: drive after rebooting from a floppy. The failed DOS installation was not bootable itself, but the file system on it looked to be roughly intact. The size of the COMMAND.COM file was the same as the one on a normal bootable DOS floppy disk. So perhaps the installer is failing at a point just after the file was copied? Still the computer does not detect a bootable DOS installation on the SD Card despite what appears to be a valid DOS partition.

10
  • You need to know the physical geometry which the IDE adapter shows to the laptop. Even if the laptop does not understand the geometry correctly when using auto-detect, the geometry still needs to be correct. How did you even guess that 1024/16/31 would work?
    – Justme
    Feb 27, 2022 at 21:38
  • Can you plug in a real IDE drive instead of the SD-thing? It often helps to swap out potential failure points to better identify where the problem lies.
    – paxdiablo
    Feb 28, 2022 at 1:10
  • Have you tried to fill the space on the SD card manually? You seem to be able to boot with the floppies, and the drive C: seems to be accepted. Format it and copy some junk files on it. How much can be written? Feb 28, 2022 at 11:39
  • Isn't the max disk size for DOS 6.22 2Gb? Try partitioning the disk into 2Gb chunks before installing.
    – cup
    Feb 28, 2022 at 14:38
  • @cup Max disk size is about 8GB, max partition size about 2GB, but likely a 386 can support only about 504MB due to CHS limit so partitioning has to be done with correct geometry.
    – Justme
    Feb 28, 2022 at 15:37

0

You must log in to answer this question.

Browse other questions tagged .