10

I have a tower PC from the early 2000's. I got this system second-hand and as-is so I do not have any original driver resources. I have installed Windows 95 mainly to play old Windows and DOS games.

Recently, I have fiddled around trying to get sound working as there were no working drivers installed. The hardware manager told me that my onboard sound card is a CMI8330, for which I found a driver online and managed to get it installed. Now, the Windows part of the machine has working sound (start-up sound, in-game sound in Settlers II).

I had hoped for sound to magically appear for the DOS game (Crystal Caves) that I was playing, too. (I know that sound exists as I remember playing the exact same diskette on a different PC and having sound in the day.) However, that did not happen. Googling told me, there needs to be a SET BLASTER= line in the autoexec.bat which wasn’t there. I did my best to look up the required values for the sound card and tried entering them. All in all, my autoexec.bat now looks like this:

mode con codepage prepare ((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys
SET BLASTER=A220 I5 D1 T6 H5
 

I have tried a number of different T values to no avail. I am confident that A, I and D are correct as entered (I did not modify the default values in the driver settings but did find those exact ones).

What else might I try to get sound working for the DOS game? Is there something I may have completely missed?

(In case it wasn’t obvious: I am accessing DOS by restarting into MS-DOS mode; the good old Win95 feature.)

0

2 Answers 2

14

To configure your CMI-8330 sound card under plain DOS, without Windows, you need to install the CMI-8330 initialisation tool. You can download it from HelpDrivers (scroll down, look for c30dos12.zip), or from the VOGONS vintage driver library.

Extract the archive and run INSTALL.EXE from plain DOS; when it asks for a Windows 3 installation directory, skip the Windows installation by pressing Enter. This will set everything up so that sound works under DOS.

This might not help for Crystal Caves however; it only uses the PC speaker. If your motherboard emulates the PC speaker using the CMI-8330 (if that’s possible), you’ll find relevant settings in the utilities described above; otherwise, you might need to find an appropriate speaker and connect it to the corresponding motherboard header.

You may also need to enable sound effects in the game: start Crystal Caves, then start a game, and inside the game, press Esc to get the in-game menu, T to toggle sound, and Y to enable sound:

The Crystal Caves in-game menu

Crystal Caves sound toggle

12
  • Okay, so if the game accesses the speaker, why is it not and what am I doing wrong? Because I’m relatively sure I heard that PC beep before … (Although that probably opens another can of worms …)
    – Jan
    Apr 15 at 12:51
  • 1
    Does it beep when you switch it on? Apr 15 at 12:52
  • I don’t think connecting the PC speaker wires to the regular sound card became popular until the latter half of the 2000s at the very least, and even then, I think it was primarily in laptops. A sound card old enough to have DOS drivers probably doesn’t have a dedicated PC speaker input (though <hw.fagear.ru/wp-content/uploads/20140811_717528.jpg> and <http2.mlstatic.com/…> do show some kind of pins where a speaker might be connected, if one is so inclined). Apr 15 at 12:56
  • 3
    @user3840170 it was reasonably common on Sound Blaster cards (commonly labeled “PC_SPK”), and some cards like the PAS16 could take over PC speaker duties without even being connected to the motherboard header. Quite a few Dell systems I used in the mid- to late-nineties handled the PC speaker using their sound card. Apr 15 at 13:09
  • 1
    @user3840170 I found out between my last comment and this that I was looking for the sound toggle in the main menu rather than during a game. Toggling sound on worked from within the main level but I expected an option from the main menu … I’ll admit, I feel a little stupid now. I’m just confused why sound was off by default rather than on as I had remembered it … but that’s certainly not a question for the comment section ;)
    – Jan
    Apr 15 at 16:49
2

All the non-original Creative Labs Sound Blaster sound cards I saw back in the day required to initialize them with some executable(s) that was part of the sound driver, which you are not doing at all. This was done either in AUTOEXEC.BAT or CONFIG.SYS or both. Even newer Creative Lab Sound Blasters need such a thing.

After searching my archives, I found out that for CMEDIA CMI8330 sound cards, the DOS driver executables are:

C3DMIX.COM
SETAUDIO.COM
FIXEPIC.EXE

I cannot test them as I no longer have a CMI8330 card on board working, and both *.COM executables throw message on me that PCI CMI8330 card is not present. The last EXE is just some fix for some games and not a driver.

If you do not have such files then try to download them; this is the first Google hit that looks promising (contains the SETAUDIO.COM file in listing): CMedia DOS Mode MPU-401 Emulator Driver.

According to VOGONS: cmi8738 pci - dos (no FX), you should add this to your autoexec.bat:

C:\PCIAUD\SETAUDIO
SET BLASTER=A220 I5 D1 H5 T4
C:\PCIAUD\C3DMIX /MFF000 /FFF000 /WFF000 /L00100 /E00100 /A00100 /C00100 /P00000 /400000 /R0f0ff /D040ff /Q0 

But its possible that the driver executables will make that entries on their own once executed.

In case you have no luck on finding those driver files, comment me and I will post them somewhere.

Another option is to install the awesome VDM sound driver on Windows and start your game under Windows. The driver will emulate Sound Blaster on any sound card that is installed in Windows; this was the only known option for newer sound cards that did not have any DOS drivers like SB 128 Live. However this will no longer work under pure DOS.

5
  • 2
    I've downvoted this answer because it's vague and doesn't help with the issue at hand at all.
    – knol
    Apr 15 at 14:16
  • The question is about running in pure DOS, VDM sound is not relevant.
    – knol
    Apr 15 at 14:21
  • 2
    @knol I reedited the answer along with the DOS driver fix I found in my archives btw. the question is about running DOS game (Crystal Caves) with sound and not about running sound in pure DOS ... its just (s)he using "pure" DOS to test this (even if w9x DOS is far away from pure DOS) ... and what do you mean by vague?
    – Spektre
    Apr 15 at 14:52
  • I said it was vague because the original version of this answer only talked about Creative's own first-party cards. The edits are an improvement :)
    – knol
    Apr 15 at 15:00
  • 1
    Thanks for pointing me to this issue which I had no idea about. After installing the driver from the other answer, the lines you point out were added to autoexec.bat automatically which is very nice.
    – Jan
    Apr 15 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.