So over the span of about 2 months I've been trying to get a USB drive together with all the tools to run an old game my uncle made. It was make for a really old computer(I think like a TRS-80 or CoCo or something) and I found an emulator but it doesn't work when I put it into the USB stick. then, I stumble across XROAR. It looks really good and my uncle will be able to play his game now, but here's the thing. the only surviving copy of the game on the internet is a .dsk file, and XROAR doesn't like that at all. I've been looking for alternatives, but none seem to work other that XROAR. I saw a tool called dsk2rom and I installed it but I have no idea how to use it. if there are better alternatives out there I would love to hear them or if this is the only way I would really appreciate it if I could get some help using it.

If the file is needed I can send a link to download

I tried to use an online emulator by saving it as an offline website, but the emulation portion of the website just didn't show up when it saved(I tried multiple times)

Well I've tried openMSX and can't get that to work. Apparently it is supposed to be able to work with .dsk files but I just can't figure out how to use it and I don't think my uncle could either.

I downloaded XROAR with the expectation to be able to run the .dsk file, but I later read that you need a ROM file for it to read.

(Edit) The game is called Touchstone. I'm hoping to emulate it on windows 10 or 7. It was released by Tom Mix Software(As far as I can remember/find in my research) and, I don't know too much about .dsk files, but If someone does know something about them I will gladly send a download link.

(Edit Edit) So there was an answer saying to download ROMs for the computer instead of the game, and i tried it but it didn't work. It's probably because i'm bad with this kind of thing, but i don't know. I remember reading something about XROAR coming with the ROMs pre-installed but that was probably wrong. Also the directory the person gave me... did not exist. I again think it is probably my lack of skill- I'm not sure what to do

  • also i'm very sorry if this is the wrong section for this question, i was told to come here by the wonderful people over at StackOverflow Dec 26, 2022 at 1:08
  • 6
    We may be happy to help, but you need to give us a little information to start with, like what game is it, for what system exactly, what is the system you want to run it at and alike. '.dsk' and '.rom' file types have been used for anything from Apple over Commodore to Zenith. Also linking to what information you have (like the mentioned xroar) also improves chances to get help.
    – Raffzahn
    Dec 26, 2022 at 1:12
  • Terribly sorry, the game is called Touchstone. I believe it was for the TRS-80, but it could work on many other systems as well. I've never had one, so i don't know. I was planning on running it on Windows 10/7, i can't remember. I downloaded the only remaining copy of it on the internet(as far as my 3 hour search could see) but it just said it was a .dsk file, i don't really know what else. I'm pretty new to this. Do you need a download link to the file? Dec 26, 2022 at 1:16
  • 2
    Please add all information available to the question, not the comments. thanks.
    – Raffzahn
    Dec 26, 2022 at 5:27
  • But don’t just slap ‘EDIT: HAHAHA DISREGARD THAT’ at the end, try to make it a coherent, legible whole. I still don’t even understand what the question actually is about. Title says something about file format conversion, but the body actually talks of picking and configuring emulators, then re-obtaining the game from a different source… it’s all over the place. Pick one problem and stick to it. Dec 28, 2022 at 13:39

1 Answer 1


Googling for "touchstone game dsk" finds e.g. this, which has two copies of Touchstone as a .zip file, and one of them can be played online with a online version of XROAR ("play now").

The zip file of this variant contains a DSK file, so it seems to me that XROAR should work fine with it (I have not installed XROAR, nor have I tried this myself).

but I later read that you need a ROM file for it to read.

Looking at the configuration of the online play, it says "Tandy CoCo" and "Cartridge: RS-DOS", so I would assume that the ROM files you need are not a conversion of the DSK file, but the ROM images for the Tandy CoCo and the cartridge.

Googling for those finds multiple sources, so download them and try them out.

From the xroar manual:

Firmware ROM image files are configured as part of a machine or a cartridge. They have a filename extension of .rom or .dgn, and can be specified as:

  • Complete path to a file.
  • Base filename of an image, to be discovered within a search path.
  • Base filename of an image, omitting the extension. XRoar will search as above, appending the known ROM filename extensions.
  • An ‘@’ character followed by the name of a ROM list.

A ROM list is a comma-separated list of images, each following the rules above. ROM lists may refer to other ROM lists. Define a ROM list with -romlist name=image[,image]…. View the defined ROM lists with -romlist-print.

To make life easier, the default image for each type of machine or cartridge usually refers to a ROM list which contains all the corresponding filenames seen in the wild, the primary examples being:

Firmware ROM ROM list Canonical image names
Dragon 32 BASIC ‘@dragon32’ d32.rom
Dragon 64 32K BASIC ‘@dragon64’ d64_1.rom
Dragon 64 64K BASIC ‘@dragon64_alt’ d64_2.rom
Dragon 200-E 32K BASIC ‘@dragon200e’ d200e_1.rom
Dragon 200-E 64K BASIC ‘@dragon200e_alt’ d200e_2.rom
Dragon 200-E Charset ‘@dragon200e_charset’ d200e_26.rom
Tandy Colour BASIC ‘@coco’ bas13.rom, bas12.rom, bas11.rom, bas10.rom
Tandy Extended BASIC ‘@coco_ext’ extbas11.rom, extbas10.rom
Tandy Super ECB (CoCo 3) ‘@coco3’ coco3.rom
Tandy Super ECB (PAL CoCo 3) ‘@coco3p’ coco3p.rom
Tandy Microcolour BASIC ‘@mc10’ mc10.rom
Alice Microcolour BASIC ‘@alice’ alice.rom
DragonDOS ‘@dragondos_compat’ dplus49b.rom, sdose6.rom, ddos10.rom
Delta System ‘@delta’ delta.rom
RS-DOS ‘@rsdos’ disk11.rom, disk10.rom
RS-DOS with Becker port ‘@rsdos_becker’ hdbdw3bck.rom
Orchestra 90-CC ‘orch90.rom’

The default search path for images specified only as a base filename varies by platform, and is detailed in Getting started. This path can can be overridden with the option -rompath path, where path is a colon-separated list of directories to search.

And the has:

After installing XRoar (see Installation), the first thing to do is make sure you have the firmware ROM images available for the system you wish to emulate. Without these, you will see rubbish on the screen (probably a checkerboard pattern, reflecting the initial state of RAM, see Troubleshooting).

These firmware images can be transferred from your original machine (with some effort, outside the scope of this document) or more likely found online on one of the archive websites. XRoar searches certain directories for these images, depending on platform, including (where ‘~’ indicates your “home directory”):

Platform ROM path
Unix/Linux ~/.xroar/roms:prefix/share/xroar/roms
Windows :~/Documents/XRoar/roms:~/AppData/Local/XRoar/roms:~/AppData/Roaming/XRoar/roms
Mac OS X ~/Library/XRoar/roms:prefix/share/xroar/roms

So you need those files and place them in the right directory. Then you need to configure XROAR to emulate a Tandy CoCo with RS-DOS. And then you should be able to attach the disk file, so it can be used via RS-DOS.

and it says it strictly runs .ROMs, not .DSKs.

It needs the ROMs to emulate the system, but of course you can also attach disks. I have no idea what you are reading, it is very clear in the manual.

Also the directory the person gave me... did not exist.

Well, I didn't "give them to you", these are in the manual. All I did is google for the manual, and quickly skim it.

These directories are the places where XROAR looks for the ROM files. If they do not exist (and why should they?), you make one of them, and put the ROM files there. Unless XROAR can find the ROM files, it's not going to work ...

It's probably because i'm bad with this kind of thing

If you cannot figure this out, and if you have no one looking over your shoulder to guide your through the process step by step, why not use the online version I linked to above? It just works.

  • 1
    That is where i got the file, and XROAR ONLINE is able to run it, but when put into a direct download of the software version of XROAR it shows the "no rom found" error. XROAR in its documentation should be able to emulate Tandy CoCo and almost every Cartridge type, and it says it strictly runs .ROMs, not .DSKs. Thank you though! I'll try it out and add an edit, thanks very much! Dec 27, 2022 at 4:49

Not the answer you're looking for? Browse other questions tagged .