8

I come from superuser.com where I asked this, but was told to post here for further help

https://superuser.com/questions/1772907/mac-mini-g4-powerpc-wont-boot-how-can-i-reset-it-to-factory-defaults?noredirect=1#comment2763052_1772907

With the help I got there I was able to remove the verbose mode, and the boot chime sound is being played again, apple logo and loding screen are showing up again

My setup is

  • Mac Mini which - PowerPC G4 model 1.25GHz from 2005
  • USB stick of 16 GB
  • DVI to HDMI converter
  • Wired logitech keyboard

enter image description here

The screens starts to flash/blink and the Apple/loading logo gets stuck forever, sometimes the login screen is displayed but the image being out of sync makes it impossible to read or use.

Therefore I have tried using the USB to boot

  • burning a MacOs 10.4 ISO into the USB
  • burning a FreeBSD 12/23 powerpc into the USB

In both cases the USB is not being shown by the boot menu

enter image description here

This computer was connected 10 years ago to a monitor with a DVI port, maybe the DVI-to-HDMI converter can be blamed for the graphic glitches ?

I was able to get into Single-user mode and I got a command prompt but was not sure about what to type there to get a working MacOs or some Linux alternative

What is the best approach to revive this maching and have a working computer, even is not with MacOs

My only Mac machine is the MacMini, so my tools to create a USB or other steps are Windows 10

UPDATE based on ssokolow answer https://retrocomputing.stackexchange.com/a/26615/26898

  • I'm using a USB 2.0 Stick of 16GB
  • I'm not using a USB hub, stick is connected directly
  • I have not found the original DVDs for the MaxOS or tests
  • I did plug the stick before powering on the Mac Min
  • I have installed and used HDD Raw Copy Tool to create the USB but still not recognized

Still the USB is not shown in the Boot Menu

4
  • Do you have an older monitor you can try with? The graphics card may have trouble supporting the resolution reported to OS X by the one you have. Commented Mar 11, 2023 at 20:14
  • Unfortunately Apple does not sell the 10.6 DVD any more They did for quite a while (probably until the stock ran out) Commented Mar 12, 2023 at 9:15
  • 1
    Are you aware of MorphOS? I had success reviving a similar Mac Mini G4 with it. It was a couple of years ago so unfortunately I can't remember the finer details but I was definitley able to boot from USB and it solved similar video problems I was having using the pre-installed MacOS. Note that it's not free, a full license is 79 EUR, but there is a 30 minute trial mode which allows you to check it out at no cost: morphos-team.net/hardware
    – robosnacks
    Commented Mar 12, 2023 at 13:38
  • @robosnacks I tried to create a robosnacks iso/usb image from Windows 10 but the USB is never shown as a boot option, only the original hard disk Commented Mar 16, 2023 at 14:30

2 Answers 2

4

I have to disagree with Jacob Krall. To paraphrase what the maintainer of one of the big Mac abandonware sites almost constantly finds himself saying in the chat while helping visitors to get their G3s, G4s, and G5s booting, the Open Firmware approach to USB boot is only for macs old enough to not have an Option-key boot menu and there's no reason to use it in this case.

If your USB stick isn't being shown in the boot menu, odds are 99% it's one of the following problems:

  1. The USB stick is too new (Use a USB 2.0 or USB 1.1 stick, not a USB 3 one. Try a different one. USB 3 never works and Open Firmware is a bit picky in general.)
  2. You didn't put it in a root port (Often, plugging it into a USB hub instead of directly into the mac will keep it from working. My 2002 G4 Quicksilver's keyboard is an extra complication in that it's so USB 1.1 that, if you plug a USB 2 stick into it while a working OS is running, you'll get a spurious "disabled because it would draw too much power" error.)
  3. You didn't plug it in before powering on the machine (Apparently there's something in how Open Firmware enumerates devices that means that the wait for things to pop into the Option-key boot screen is all about examining the contents of the drives, not enumerating which drives are available.)
  4. You wrote the image incorrectly (Among other things, pre-Intel Apple stuff has its own partition table format, so you need to use something like dd (on Windows, HDD Raw Copy Tool is what he recommends to people asking for help) and write the image directly to the root of the device (i.e. /dev/sdX, not /dev/sdX1) without alteration.
  5. The image isn't compatible (Make sure you have either a retail 10.4 disc (the black kind with the big white X on it) or the exact SKU of grey (or, infrequently, some other solid color) disc that came with your mac. The grey discs bundled with macs are extremely model-specific and, if they work on a model not meant for them, it's because you found an oversight in Apple's blacklisting code... and that's not good because they'll be missing drivers or cause mysterious misbehaviours if installed. Also, he recently mentioned while helping someone that some mac models are fine with the 10.4 DVD release but can be problematic if you want to install the release on multiple CDs for some reason. Also, try imaging your disc differently. Maybe the tool you used to make the disc image doesn't produce raw images that can be dded onto a USB stick.)
  6. Your virus scanner's boot sector protection may have mangled your attempt to write the image to the USB stick.
  7. If you're trying to install exactly the version number that your model originally came with, you may need the model-specific restore disc, because Apple makes the software adapt to the hardware instead of vice-versa. (eg. I have an Intel iMac that came with Mac OS 10.6.3, but it won't run the retail-disc version... only the later 10D2322a build that never got a retail release.)

Another technique I've seen if you've got two compatible macs (i.e. Same ISA and both use the same interface for target disk mode) is to put the one you want to install onto in target disc mode, hook it up to your other mac, and then install the base OS and any updates required for compatibility onto it as if you were setting the other machine up to multi-boot.

As a last resort, another option is to pull the hard drive out, plug it into your modern machine (using a $3 IDE-SATA adapter of the correct type if needed), image the root of that with the install disc, use Option-key boot, and then add a partition to install to in the remaining free space and install as normal.)

maybe the DVI-to-HDMI converter can be blamed for the graphic glitches ?

I've never seen that particular kind of graphical glitching from them (I usually just fail to get sync from a monitor if one of those passive adapters is bad), but I suppose it's possible. I did see a DisplayPort-to-DVI adapter that was noisy enough to introduce brief, infrequent one-pixel-tall horizontal flickers of green.

Those buttons look unnaturally low-res, which suggests either the mac isn't getting good EDID or the monitor isn't handling what it's being sent properly. (eg. When I put my G4 behind a simple VGA switch box to share the monitor with my PS/2-based Win98SE retro-PC, the early phase of MacOS 9.2.2 boot dropped to 640x480, the name in the Monitors control panel went generic, and the Mac gained a requirement that the switch box be set correctly during boot to initialize video output, because the switchbox doesn't pass EDID at all.)

If those vertical lines are rapidly changing position, my first test would be to try a different adapter/cable (i.e. I'd suspect the connection is too noisy and those lines correlate to specific conductors in the adapter or cable).

If they're more or less stationary, my intuition would tell me to check for bad capacitors or video RAM.

I don't suppose you still have the Apple Hardware Test disc that was packed in with the grey disc set for your machine? (I ordered some new DIMMs to bump my G4 up to 1.5GiB after I finally diagnosed my AHT disc refusing to boot as "apparently AHT is more sensitive to one of the DIMMs being bad than MacOS 9.2.2 or 10.1 are" and it does run a test for the GPU.)

If not, source one. I'm not sure what specific version number range works on your machine, but my set from 2002 has version 1.2.5, so don't waste your time trying anything less than 1.2.6.

(In case it's helpful for your diagnosis, the "some of the system RAM is bad and AHT is fragile" symptom I experienced is that it does show up in the boot menu, but the loading screen crashes out to an Open Firmware "DEFAULT CATCH! code=300".)

1
  • I have updated my question after following your advice, the USB stick is still not shown on the boot menu - I have only Windows machines to create the USB sticks using the HDD Raw Copy Tool Commented Mar 12, 2023 at 19:47
1

PPC macs aren’t easy to boot off of USB. It’s possible, but you will have to spend time in OpenFirmware. It would be easier if you could get an optical disc to boot off of.

10
  • good to know, any reason why the video image looks like that ? Commented Mar 10, 2023 at 15:54
  • @MauricioGraciaGutierrez I think you have the correct hunch on the picture quality problem: the DVI-HDMI converter is suspect. Commented Mar 10, 2023 at 18:43
  • 1
    I would say that the picture quality is more to do with the aspect ratio of the screen being wrong (most displays were still 4:3 in 2005), and the display not knowing what to do with a now unusual resolution. There is no conversion between DVI and HDMI, its the same digital signal.
    – camelccc
    Commented Mar 10, 2023 at 19:52
  • 1
    I wouldn't worry about it. Once you got OSX or Linux booted, either should support a 16:9 aspect ratio with most hardware of the time (possibly with some fiddling) The fact that the boot process looks off isn't going to affect much. DVI hdmi is a straight adapter, it just needs to connect pins together so it will either work or not if it is broken
    – camelccc
    Commented Mar 10, 2023 at 20:05
  • 3
    Have you tried another monitor? The video resolution can be poorly supported, or the monitor may support poorly DVI protocol on HDMI input, as it might assume HDMI protocol is used on HDMI input.
    – Justme
    Commented Mar 10, 2023 at 20:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .