I have a Toshiba laptop and I am not sure what is going on with it. Thinking that maybe the computer was corrupted 20 plus years ago. Trying to fix it up.

When the laptop boots, I can see this on the screen:

Text-mode screenshot of the system booting; the screen displays C→\▲SET MSINPUT↔C→\MSINPUT on one line, and the caret is displayed below

About 20 to 30 seconds later, the command disappears and I get a blank screen. If I blindly play around with Backspace, Enter, and other keys, I can actually get it to start (the Windows 98 startup chime can be heard) and it acts like I am on the desktop, but I cannot see anything. Also notice the funny looking characters: where the colon should be, there is an arrow... It is like this on other screens as well, with double exclamation points replacing characters and so forth. I know the screen works because it displays the initial toshiba message and I was able to see a BIOS menu (once). Have not been able to get there again.

I am able to press and hold F8 to go into Safe Mode successfully, but not sure what to do in Safe Mode. I tried refreshing various displays, but have not had any luck. I also tried installing the hard drive in another computer and booting it there: I did not get the full desktop (it asked me to install drivers for new hardware first), but the funny fonts were gone and it showed standard characters.

Wondering if the operating system is corrupted. Do I need to reinstall the OS? Can I bypass the command? If anyone has experienced this weirdness before, I would appreciate advice on what to do to actually be able to use the laptop normally. Thanks in advance.

  • 2
    It's not "asking for" anything. That is just an echo of a legitimate command from autoexec.bat (though you have some weird font/character code issues). MSINPUT is something to do with 'Intellitype' support for certain keyboards. See here.
    – dave
    Commented Mar 23, 2023 at 17:14
  • 3
    FWIW, the previous post was from an unregistered account, so maybe 'Shawn Hardgrove' cannot edit the original. Mods, is there some way to attach the old question to the new registered account?
    – dave
    Commented Mar 23, 2023 at 17:20
  • 1
    @another-dave There is, but mods aren't allowed to do it any more after the Incident. Instead, use the contact us form to contact Stack Exchange employees.
    – wizzwizz4
    Commented Mar 23, 2023 at 21:09
  • 3
    Thanks for the heads up all. I contacted CS to see if they can combine my original question with this one. I was having trouble editing the original question, so I decided to register and repost.
    – vintagepls
    Commented Mar 24, 2023 at 1:10
  • 3
    Off the screenshot alone, it looks like the ASCII range [0x3a, 0x3e] is corrupted into [0x1a, 0x1e] (bit 5 forced off) in screen memory. Can you run a thorough memory test (a la memtest86 or something similar)? Maybe it can reveal something more. Commented Mar 24, 2023 at 12:11

3 Answers 3


This is not a full diagnosis, but one hypothesis can be formulated just from the screenshot.

It shows a setting from AUTOEXEC.BAT printed to the screen during booting. What the setting does is immaterial; the interesting thing is that the line that would ordinarily look like C:\>SET MSINPUT=C:\MSINPUT, here is displayed as C→\▲SET MSINPUT↔C→\MSINPUT. This corruption of video memory is not quite random: mapping those characters to code page 437 code points, we see that : (0x3a) is corrupted into (0x1a), > (0x3e) into (0x1e) and = (0x3d) into (0x1d). In other words, bit 5 of the character code is cleared. This sort of thing is suggestive of a hardware fault, for example the fifth data line of the memory bus being broken. This is somewhat corroborated by the fact that the symptoms disappear when the hard drive is booted in another computer.

Given that the system otherwise seemingly runs normally, and all symptoms as described seem limited to visual problems, one should hope the problem is contained entirely within the video adapter. But there are other possibilities: it may be a problem with the mainboard itself, with the memory bus, or perhaps with the RAM modules. It would take dismantling the laptop and thoroughly inspecting it to precisely locate, confirm and repair the issue. Before you attempt that, running a thorough memory test like memtest86+ may reveal more (note: the official binaries require a Pentium, which may or may not be a show-stopper, depending on how old the laptop is). Installing an alternative video adapter may be unfeasible, though given that you have not revealed the laptop model, I cannot tell how much.

Of course, there is still the possibility that this is the fault of bad DOS or Windows driver. To check that route, you can follow the steps in Michael Karcher’s answer. You can also try interactive boot mode (‘Step-by-step confirmation’ in the F8 boot menu) to pinpoint the driver at fault. However, if the issues start appearing before any driver loads, or even in ‘Safe mode command prompt only’ mode, there is little hope: it’s almost assuredly a hardware problem.


If booting into safe mode works, it means that your machine is basically working. The issue only occurs when you load additional software that gets skipped when you boot normally. This extra software might be some stuff from autoexec.bat, or it might be a windows graphics driver.

Please try the following troubleshooting steps:

  1. Try to boot into "command prompt only" mode (not "command prompt only for safe mode"). If the computer works perfectly in that mode, the issue is not in CONFIG.SYS or AUTOEXEC.BAT.
  2. If the issue occurs in "command prompt only" mode, use the confirmation mode to find out what what line of CONFIG.SYS or AUTOEXEC.BAT causes the issue.
  3. If the issue does not occur in "command prompt only" mode, try to re-install the Windows 95 graphics driver, by booting into safe mode and uninstalling it.

Since it can boot and run the startup programs, it would appear to not be a problem with the disk or the RAM. It seems to be more like the video card, although that's not going to be removable if it's a laptop. Nonetheless, there is another possibility, that being the printer driver. Since you can get into safe mode, try removing the printer. I have rescued machines in the past by doing this, so it's a less than wild guess.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .