I have obtained Amstrad CPC6128 with Locomotive BASIC 1.1. Everything works fine except one thing. I don't know how to properly run certain .COM files. I have tried general commands such as RUN or LOAD with no luck. The files for some reason are not visible from CP/M with DIR command. Probably because the disc is in DATA FORMAT?

EDIT - Clarification: The CPC6128 computer comes preloaded with Locomotive BASIC 1.1 in ROM. All files on all formats of discs, including the .COM files in question are accessible on discs from this BASIC with CAT command.

I do have AMSDOS.COM on some discs but it's the same story. It's a .COM file I'm asking about how to run properly. If I run the AMSDOS from CP/M it seems to just go back to BASIC. I don't care about AMSDOS if I don't need it.

The CP/M version is 2.2. In this version of CP/M that I have the files can't be listed with DIR command if they are on a "DATA FORMAT" discs. I can only list the files if they are on a "SYSTEM FORMAT" disc.The discs were verified with a DISCKIT2.COM that I run from the CP/M disc.

To clarify - the .COM files I want to run are on a floppy disc which is formatted in a "DATA FORMAT". I can list files with CAT in BASIC 1.1 but not DIR in CP/M 2.2.

EDIT 2: Turns out everything works with CP/M Plus. I was using CP/M 2.2 before.

  • 1
    I've added an edit to my question with all the clarification I could come up with. Please let me know if there are any other ambiguous or missing info you'd like me to add. Sep 2, 2023 at 18:11
  • 3
    If under CP/M 2 you type STAT *.COM do the files show up then? (You will need a copy of STAT.COM). If they do show up but with their names in brackets then they have been set as system files.
    – john_e
    Sep 2, 2023 at 22:41
  • 2
    Are you aware that CP/M has the concept of a "user" that marks directory entries with a 4 bit number? See the last paragraph on this Wikipedia page. Depending on the current user, not all files are accessible. Sep 3, 2023 at 9:06
  • 1
    Aside question: where did these disks come from? Is there any chance that they've been produced by somebody who didn't realise the disk formatting requirements for running under CP/M and has written them to the wrong sort of disk format? E.g. by downloading software they want, using a tool to construct and write an Amstrad disk image? Obviously the motivation for my question being whether the answer to yours might be "move the files to a properly-formatted disk".
    – Tommy
    Sep 4, 2023 at 2:24
  • 1
    Actually, AmsDos "data" format disks should be perfectly readable by Amstrad CP/M. If you cannot see files, probably the disk is corrupted or the files are stored with a different USER. Another difference is obviously you cannot boot from them
    – tofro
    Sep 7, 2023 at 10:31

3 Answers 3


These files are indeed intended to be executed from CP/M. AMSDOS.COM, for example, is intended to return to the "native" AMS environment from CP/M.

Likely, you'll be having the following files:

  • CLOAD.COM - Allows to load a file from cassette into the computer and transfer it to disk
  • CSAVE.COM - The opposite of the above
  • CHKDISC.COM - byte-by-byte compare of two disks
  • DISCCHK.COM - same as above, but but for use when you have only one drive
  • COPYDISC.COM - what the name says, for two drive operation
  • DISCCOPY.COM - same as above, but for one single drive
  • FILECOPY.COM - copy files between disks and user areas, for single-drive usage (as opposed to PIP.COM)
  • FORMAT.COM - what it says...
  • SETUP.COM - Allows to set some boot parameters on CP/M disks

Why your disk is in "DATA" format is likely a different question. Probably, because the DATA format provides the highest capacity, or, maybe someone has copied these files not knowing they need to be on a CP/M disk.

Why you cannot seem to be able to read the disk at all from CP/Mis yet another question: Disks in DATA format should be perfectly readable from CPM. (Are you trying to boot from that disk? That won't work. To read such a disk, start CPM with a CP/M disk in the drive, change disks, then do a DIR.)

  • Thank you for your input. To answer your question, no, I was not trying to boot from it. I booted from other disk with CP/M 2.2 and that might have been the problem. After booting from CP/M Plus everything works as intended. Sep 26, 2023 at 8:48

After downloading CP/M Plus and copying it onto a spare floppy the *.COM files in question are visible and accessible. Apparently there are some differences in file system handling between CP/M 2.2 and CP/M Plus. The disc i was trying to read off was probably created in CP/M Plus and therefore was (for unknown to me reason) unreadable in CP/M 2.2. Thanks everyone for your input.


Indeed, AMSDOS.COM is the opposite of |CPM. See the book Soft158A chapter 4.1.

  • 3
    This is not an answer to the question. Sep 7, 2023 at 17:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .