4

OK, so I was gifted a Mac Plus a couple weeks ago, and finally got it up and running a couple days ago (had to wait for mouse and a couple lots of disks for it to arrive, since it came as just the Mac and keyboard).

The first batch of disks worked fine and I spent a good afternoon testing things out, flipping things back and forth as requested, etc.

The second batch arrived today, and it took a bit of a different course. I put in the first disk of the Microsoft Word 5.1 install set and it read it fine. Not having an HD for the Mac at present I decided not to run the installer, but I thought I'd put disk 2 in to see how it came up.

It came up with a message that the disk needed minor repair, and offered to do it. I said sure, and accepted the offer to repair the disk, which it ejected thereafter.

From there on every disk I inserted would be greeted with a message "This disk cannot be read" along with an offer to eject the disk or reformat it as a one- or two-sided disk. Even the System 6.0.8 disk I booted that session with produced this when I put it back in.

Even after a restart it's still rejecting any disk I put in there, including known good boot disks.

Did I just watch the disk drive fail in real time, or is there something else that might be in play? Looking for suggestions on what to do next.

2
  • 1
    @agarza Thanks! Didn't know that had its own SE now, and wasn't sure where else to direct this.
    – Kaji
    Nov 4, 2023 at 7:37
  • 3
    Both the disks and the Mac Plus are O L D. This disks potentially not as old as the Mac. I would bet that the floppy drive needs cleaning/servicing and that you did witness (possibly) the drive fail, possibly due to a defective floppy disk. Nov 4, 2023 at 14:18

1 Answer 1

3

This is typical of a drive failure. Your best bet is probably to try to clean the drive first, since a dirty drive is the most common (and easiest/cheapest to fix) way a drive can stop functioning. A moldy or very dirty disk can muck up the drive in a single load.

You have a couple options here if that's the troubleshooting route you want to take:

  1. (easier, but less precise): Use a floppy drive cleaner like this one
  2. (Slightly harder, and more tedious): Disassemble the Mac and clean out the drive. This can be a bit tricky given the CRT and the hard-to-reach T15 screws that hold the case together, however with some patience and watching a few videos on the topic it's not too bad.

If you want to make sure it's not something more serious (e.g. the disk controller didn't die), you can plug in an external floppy drive, or floppy drive emulator (like the FloppyEmu), and if that drive works it's likely just the original drive that has gone bad.

Best of luck!

3
  • 1
    Thanks for the tips! Have ordered a cleaner kit to try that out first, then will try the manual cleaning afterward if needed.
    – Kaji
    Nov 4, 2023 at 21:56
  • No problem! Good luck with the disk!
    – nboyko
    Nov 4, 2023 at 22:21
  • 1
    It worked! One run with the head cleaner disk and it started booting normally from known good disks again.
    – Kaji
    Nov 21, 2023 at 3:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .