1

I have a Windows 98 Pentium II computer which behaves strangely. Although the CD-ROM opens and closes, I can't see it in Device Manager or play music. I get message that there is no CD-ROM device installed.

I tried to start the windows in Safe Mode and I deactivated/erased the CD-ROM but when I restarted the system and I started normally Windows 98, I wasn't able either to use it or see it in Device Manager, although it is functional (opening/closing).

One thought would be to replace the cable that connects to the motherboard. But I am really struggling guys and if anyone ever faced something similar, is more than welcome to answer me.

The CD-ROM is this one: Ultima CD-ROM Drive ACD-409 CD/R IDE Desktop 40x and the cable between the drive and the motherboard is plugged in. Also, in Bios, where I can check if CD-ROM is recognized by the motherboard. Besides that, the drive is connected to the floppy drive as well and that same cable is plugged into the motherboard.

Solution:

I cleaned the contacts, with wd 40 electronic cleaner and plugged them in and out several times. Then I plugged them in and problem solved.

Remember you must clean the contacts both in cd player and the motherboard in order to have the desired result. Also you can change the cable that connects cd player and motherboard.

16
  • 2
    The answer will depend on what model of CD-ROM drive you have, and whether it's IDE or SCSI. Can you tell us what motherboard you have and what CD-ROM drive you have?
    – knol
    Nov 6, 2023 at 9:34
  • 1
    It clearly gets power but you must tell if it is an internal or external drive, and how and where does the data cable connect. Check if cable is correctly in place, not loose or upside down. You may need a driver for your adapter. If BIOS sees the drive then that's a windows driver issue.
    – Justme
    Nov 6, 2023 at 10:46
  • 1
    Has the drive got a separate “play” button? Can you check if autonomous audio playback works? Nov 6, 2023 at 12:17
  • 2
    Do you see the CD-ROM drive in BIOS? You also said the CD drive is connected with same cable to motherboard than floppy drive. Which is impossible. Unless it's an IDE LS-120 floppy drive. There may be reasons why it is not visible. Maybe IDE ports are disabled or special RAID controller ports. Maybe the CD drive is just broken.
    – Justme
    Nov 6, 2023 at 22:12
  • 2
    Well the solution was pretty simple.I cleaned all the contacts with w40 electronic spray cleaner and plugged them in. Then it worked
    – Neo
    Nov 22, 2023 at 21:30

0

Browse other questions tagged .