6

I've got an atari 800 XL that is broken - when I power on, there's no reaction. It seems there is at least something sent to display, as TV detects a signal, and turns full black.

The chips are soldered in, not socketed, so I cannot remove and swap them with working ones (And I do not have any spares anyway, so that kind of diagnosis is impossible in my case.) There are no visibly broken parts, capacitors are not bulging, and no IC's turn hot, so there are no obvious faults at play there.

I do however have a multimeter and logic analyser (sadly, I do not have an oscilloscope), but no knowledge as to what should I check, what voltages should be at which points, and what signals chips send on which pins.

Is there any sort of guide as to what to check in such case, or anybody with the know-how can please share the knowledge?

(If that changes things, there's a memory mod installed that I cannot, and won't even attempt to remove)

  • Have you checked the output voltage of the power adapter? – Stephen Kitt May 3 '17 at 20:00
  • 3
    The 800XL field service manual will no doubt come in handy too... – Stephen Kitt May 3 '17 at 20:02
  • Yes, I did check power adapter, all OK. As to service manual, I'm checking it right now, thanks. (Still, I do not have working IC's to compare to) – user905747 May 3 '17 at 20:18
4

You mentioned in a comment that you are checking the field service manual. Which is good. That should give you some indications as to which pins of each chip (or the main ones) are VCC, GND, etc.

A few things to check are:

1) Find the voltage regulator on the motherboard. The power supply is more than likely going to be stepped down and sent through a voltage regulator. Check the power on it to make sure the board is getting a clean supply. I don't know if the 800XL has AC power or not (like the C64 does). But check too if it does.

2) Black screen could be a sign of bad RAM. Locate each RAM IC and check the voltages against what the datasheets say they should be.

3) You mentioned you have a logic analyzer. You should be able to probe the data pins on the CPU and the address pins. They should show a LOT of activity. A data pin on the CPU that is solid is a sign the CPU isn't working (or the glue logic driving it).

4) Screen is black, do you hear any audio beeps if you allow the notepad to load? If you get audio beeps then the Pokey should be good but the Antic or GTIA might be bad (process of elimination).

Try those and let us know.

  • The service manual also has specific investigation tips for a black screen, but they’re rather lacking in detail (the clock circuit needs to be verified in particular). – Stephen Kitt May 4 '17 at 22:03
  • cbmeeks, what do you mean by "allow notepad to load"? – user905747 May 5 '17 at 21:47
  • Stephen Kitt, how can I verify the clock circuit? The only thing that comes to my mind is a frequency counter, however I do not have such a device :( – user905747 May 5 '17 at 21:49
  • @user905747 if you turn on an Atari 800 and don't load BASIC, it loads a simple typing program called , IIRC, "notepad". As you type, it sends a beep through the Pokey. – cbmeeks May 7 '17 at 3:13
  • So here's what I got so far: It seems that oscillator Y1 is working OK - resoldered a spare. Still the same thing. Antic and gtia also work OK - resoldered them to 65XE, they do work. POKEY resoldered to my 65XE also seems to work, but I noticed something interesting - The power led on 800xl does not light on all the time - it stays for a few seconds, then it dulls out, then it brightens, as if there was not enough power delivered. But if i check with multimeter, there's about 4.95 V delivered to various components, and POKEY seems to work when swapped to my 65xe, so I don't know :/ – user905747 May 11 '17 at 21:14
0

Holding the option button while turning on the 800xl should take you to the built in notepad. It also bypasses the self tests I think.

0

How do you connect your Atari to your display? Is it the modulator that it comes with? I had the same experience with the "modulator". I ended up getting a monitor cable - din to composite and got the video and audio signal that way.

  • Forgot to mention, I used an older Toshiba 14" TV with a composite input to make it work. – Rob From Oak Aug 7 '18 at 18:39
  • 1
    Could you rephrase this more as an answer, as opposed to a request for clarification from the OP? There's an edit button on your answer, which you probably missed; it's that grey text on the left juuuust below your answer's text. You can add the information into the answer that way. I recommend starting with something like "If you're connecting your display with the modulator that [Atari or display - ambiguous] came with..." but you can write whatever you want. Also, this isn't like most forums you'd have used before so you might find our on-boarding tour useful. – wizzwizz4 Aug 7 '18 at 19:35
  • Or you could submit this as its own question. But first look through the other questions to see if it has already been answered. – snips-n-snails Aug 7 '18 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.