I am currently having issues while trying to use ADTPro to connect to my Apple IIc and was wondering whether anyone could help me. I am using this serial connection kit and trying to bootstrap from ADTPro, but no matter what I seem to try it always ends up sending garbled text to the Apple IIc. I've tried it with my Mac and my Windows PCs and both produce the same result. For what it's worth, "PRINT PEEK(64447)" returns 0 so it seems that my Apple IIc shouldn't have the chip with the timing issue, but I can't quite put my finger on what is going wrong and I haven't found anyone else with the same issue. Here is a picture of what the garbled text looks like:

enter image description here

Update: Further testing with the baud rate set to 300 (on both PC and Apple IIc) and using Tera Term shows the following interactions with input from Tera Term:

  • @ types successfully
    • 01000000
  • A sometimes becomes P
    • 01000001 vs 01010000
  • a sometimes becomes X
    • 01100001 vs 01011000
  • B sometimes becomes h
    • 01000010 vs 01101000
  • C also sometimes becomes h
    • 01000011 vs 01101000
  • D sometimes becomes t
    • 01000100 vs 01110100

Perhaps there is a pattern there.

  • 2
    This looks more like a baud rate problem to me. An affected serial chip should at least partially receive correct data. But your screen contents looks completely garbled. Or was there some readable text that has scrolled off the screen?
    – tofro
    Commented Mar 18 at 21:58
  • @tofro All gibberish from what I can tell, from the start to the bottom. Adjusting the bootstrap speed settings to 2400 just made it print all x's, and adjusting the "pacing" doesn't seem to make a difference.
    – Idrees
    Commented Mar 18 at 22:52
  • 1
    Do you have actual terminal software for the //c? Like Ascii Express or something similar? I would fire up a terminal on both sides and see if just typing characters back and forth works. If that test fails, I would try using a different computer to talk to the Apple (maybe ditch the USB to RS232 in favor of a real serial port on another computer). The thing I would try to nail down is, does the //c communicate in a terminal just fine? Does it only corrupt data when the USB is used? etc.
    – Geo...
    Commented Mar 18 at 23:07
  • 1
    We need a bit more information: The screen shows an attempt to start the Speediboot bootstrap? You did do the <CTRL>A14B dance? Actually, you should see the Apple enter the monitor - but from your screen its clear it stays in BASIC.
    – tofro
    Commented Mar 18 at 23:21
  • @Geo... I do not unfortunately, and I do not own a computer with a serial port either. Perhaps I can find some way to "bootstrap" a terminal client by hand? For further context, I do own the system utilities disks and they boot successfully if that provides any useful tools.
    – Idrees
    Commented Mar 18 at 23:52

1 Answer 1


It turns out the issue lied in the IIc null modem cable. After receiving a replacement, the connection worked perfectly and I was able to immediately load ADTPro via the bootstrapping process.

  • 1
    I'm glad it was the null modem and not the serial port on the //c!
    – Geo...
    Commented Mar 22 at 23:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .