4

I have this old Windows 98 Aptiva IBM which I can't seem to get out of DOS mode or boot from a CD. When I switch it on, it goes through the BIOS checks and then prompts me to click enter to boot or F1 for setup utility. When I actually boot to Windows 98, it is in DOS mode, and when I try to activate the GUI with the win command, it says "VFAT Device Initialisation failed" on a BSOD, followed by "system halted". It has something between that which I forgot. But anyway, I burned a Windows 98 SE ISO to 4 different CDs, set CD to be primary boot option in BIOS, then tried to boot from it by putting it in and switching it on, but it still doesn't work. So there is a big explanation but the question is: how can I get this thing to boot from a CD?

  • Welcome to Retrocomputing Stack Exchange. It looks like you may have two issues there - VFAT looks like something to do with the hard disk formatting so I presume that the VFAT device would be the hard disk itself. I could be completely wrong in this assumption though. Make sure to read the tour. – wizzwizz4 Jul 16 '17 at 14:36
  • 1
    You might want to try running scandisk from the MS-DOS prompt to check the hard drive for errors. You could also try booting Windows in safe mode with win /d:m. – Ross Ridge Jul 17 '17 at 5:03
  • Can this machine boot from CD at all? Some early 586 era BIOSes can not! – rackandboneman Jan 2 '18 at 14:26
5

Firstly, many old computers had problems with booting from CD; It was either unsupported or very buggy. Secondly, even if booting from CD would work on that particular Aptiva, i doubt that booting from a recorded CD would - it has something to do with the way data is written to the disc (many pre-1997 (the year recordable CDs were introduced) CD-ROMs have problems with reading burned CDs).

I would go with booting from floppy with Windows 98SE loader disc (all you need is DOS and CD-ROM drivers installed on it). The procedure would be to go to D: (or R:, or any other letter that MSCDEX would tell you to), enter the WIN98 directory and launch setup.exe

Other solution is booting from floppy with Plop Boot Manager - it's more flexible, as you'll be able to actually boot from CDs not based on DOS (for example Linux install CDs), and maybe even boot from USB drives!

  • 2
    @MattLacey I almost always use this method, but with a slight change. Firstly, I prefer qemu over VMware; I use qemu with real devices, so i don't need to dd anything afterwards. Other method that I use is install DOS in the qemu (format c: /q /s), mount the HDD, copy installation files from the ISO/CD/Floppy (everything from win3x/WIN95 dir/WIN98 dir/I386 dir), move the HDD to your other machine, launch it from the HDD, launch the installer from there. It's particulary useful if you don't have a CD-ROM in your machine, because after install you can point windows if it would ask for CD. – redsPL Jul 17 '17 at 8:34
  • 1
    @redsPL In this case the hard drive already can already boot the MS-DOS command prompt, so he'd just have to put the hard drive in another computer and copy the CD-ROM to it normally. He might even be able copy the files from the CD-ROM to the hard disk on the IBM Aptiva by loading the MS-DOS CD-ROM drivers, assuming that the Aptiva's CD-ROM drive works. – Ross Ridge Jul 17 '17 at 17:17
  • 1
    Hmmm, burning CDs at retro speeds is not something I'm nostalgic for. At least on a modern machine you can still do something as extreme as moving the mouse while burning! – Matt Lacey Jul 18 '17 at 4:36
  • 1
    belive me or not, back in the day when i burned them, typing on a keyboard was sometimes too much for the CD-ROM to handle :^) But yeah, true nowadays. – redsPL Jul 18 '17 at 7:17
  • 1
    @MattLacey I had a CD burner early. I don't remember exactly when, but certainly around the time Windows 95 came out. What I do remember was walking very carefully near the computer while a burn was running. It was a 2x drive, so that could easily take half an hour! – a CVn Jul 19 '17 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.