6

I have a Macintosh LC II that I just acquired. When I attempted to power it on, I got nothing. No tones, no LED, no fan...nothing.

I took out the power supply and tried to measure any voltage coming out but my multi-meter indicated 0 volts.

I removed the case to check the fuse (shame on you Apple). The fuse looks good. I got good continuity across the fuse. All of the capacitors look good. No leaking, no bulging.

The only thing I get is a very faint clicking sound inside the PSU. About 3-4 times per second.

I can provide the exact model number of the power supply if that would help.

Any ideas on what the problem is? I suspect it would be easier/cheaper to find a replacement.

Thanks for any suggestions.

  • forums.macrumors.com/threads/… – Cody Gray Jul 28 '17 at 12:32
  • @CodyGray I have probably 80+ vintage computers. Last time I counted was 2-3 years ago and it was 56 IIRC then. I'm working on building an inventory system because I lost count! Anyway, I mostly get them off eBay. A few have been given to me and I've bought a few from Craigslist. But a vast majority of them have been eBay finds. – cbmeeks Jul 28 '17 at 18:30
  • Sounds like a short - have you tried disconnecting the board and measuring the PSU by itself? Don't let it run like this for more than a minute, it probably doesn't like zero load. – Zac67 Jul 28 '17 at 18:31
  • @Zac67 yes, I've tested just the PSU with nothing on it at all and I still hear the clicking. – cbmeeks Jul 28 '17 at 18:35
  • Could still be caps - the ticking might hint to a switching PSU that does not properly start oscillating – tofro Jul 28 '17 at 20:44
7

The ticking indicates restarting of the power supply by the controller, probably due to a short. The short would have to be on the OUTPUT (low voltage) side (shorted AC-side devices would have taken the fuse out).

Power supplies of that era didn't suffer burst capacitors as often as the post-2000 years. The most likely cause of overcurrent is a shorted fast-recovery diode in a DC output circuit.

Look at CR51 ("C82M") and CR52 ("B82M"), one of those is probably shorted (either side pin to the center should read as a diode, center=cathode).

A suitable replacement (has to be fully insulated "fullpak") without the Japanese part number (because TDK made these supplies) might be MBRF2045CTG, from ON Semiconductor. The same power supply was in LC, LCII, Performa 4nn, Quadra 605... but there were earlier versions as well, so my part numbers might not be the same as yours.

2

The LC (and LC II) power supplies are build very tight. When running, heat spots build up inside, especially with higher load (Ethernet card, fast disk, external floppy drive, term power for external SCSI termination, …).

I have a LC with no bad caps in the power supply but a lot of cracked soldering pins, especially around components which generate a lot of heat. This can result in a multitude of erratic behavior. I recommend to re-solder the whole board. Take care of component pins which have a thick oxide coating because of prolonged exposure to heat in a cracked solder spot. If re-soldering this particular component doesn't look as expected, take out the part and scratch the pin blank. Apply solder and put it in again.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.