1

I've begun forcing myself to learn the basics of Windows 98, since I figured that it was essential to have knowledge of computing before Windows XP and Ubuntu 12.

After successfully creating a boot disk and installing Windows 98 on my Compaq (Presario, SR1503WM) tower, I decide to attempt to install DOOM (1993), since it's one of my favorite shooters. I burn the (uncompressed) contents of my DOOM zip file to a rewritable DVD and slip it into my tower.

Upon entering dir D:, I receive this output:

Volume in drive is MS-RAMDRIVE
Directory of D:\
File not found

After trying and trying again, I slip my disc back into my Windows 10 Laptop, and there I see my doom files. So I assume this is a driver issue?

Below is some extra information, which I'd been told to add. (From the Microsoft page)

Info:

In my config.sys, under [CD], are the following lines:

device=himem.sys /testmem:off
device=oakcdrom.sys /D:mscd001
device=btdosm.sys
device=flashpt.sys
device=btcdrom.sys /D:mscd001
device=aspi2dos.sys
aspi8dos.sys
device=aspi4dos.sys
device=aspi8u2.sys
device=aspicd.sys /D:mscd001
files=10
buffers=10
dos=high,umb
stacks=9,256
lastdrive=z

Note: All of the above .sys files are located in C:\rmcd.

And I've added a line (lh c:\rmcd\mscd.exe /:mscd001) to my autoexec.bat, under @ECHO OFF.

  • 3
    Are you sure your CD-ROM drive is D:? From the output, that looks like a RAM drive. Try E: instead (or look at the MSCDEX output). – Stephen Kitt Dec 24 '17 at 11:51
  • Note that there were two routes before XP - the 95/98/ME route or the NT/2K route. XP is based on the NT/2K route with some bits of 95/98/ME. – cup Dec 25 '17 at 7:06
  • @StephenKitt I'm fairly sure that D is my drive. But I could be wrong. When moving to drives A and B, they tell me to insert a diskette before moving to that drive. – user7403 Dec 26 '17 at 0:32
  • A: and B: are one thing, D: etc. another — your CD-ROM drive’s contents wouldn’t identify themselves as MS-RAMDRIVE... – Stephen Kitt Dec 26 '17 at 10:28
  • Plus if D: really was your CD, and the CD wasn’t recognised, DIR D: would print an error, not list an empty drive. – Stephen Kitt Dec 26 '17 at 12:38
3

Check the format your CD writing software is producing; these days there are two major formats, UDF and ISO9660/Joliet. Versions of Windows older than Windows 98 SE, however, only understands ISO9660 or Joliet so would be unable to read a UDF-formatted disc. If your Win98 is not SE, or if your writer software is using more recent extensions to the UDF format than the version 1.02 format that Win98 understands, then this is likely to be the problem.

  • So installing 98SE would most likely eliminate the problem? – user7403 Dec 23 '17 at 23:54
  • @S_a_DOS - unless your writer is using a more recent version of UDF. But honestly, the easiest approach is to use writing software that'll make a Joliet-formatted disc. I tend to use ImgBurn for this - on the options tab pick "ISO9660 + Joliet" for the format - because it gives very good control over all the options, but really just about any disc writing software except the built in Windows one should be able to do it. – Jules Dec 24 '17 at 11:26
  • 3
    I have some vague memories about 'finalizing' CD-ROMs back in the day. Something about the session being left open, so you could append to the disc... I think I remember sometimes a non-finalized session would be readable on some systems, but not readable on others. I never burned a lot of discs and it was a long time ago, maybe I'm crazy. – Geo... Dec 24 '17 at 13:56
  • 1
    @Geo... -- that's another possibility, particularly if the drive the disc is being read in is a DVD-R driver rather than a writer. "Finalizing" a disc writes a table of contents that some read-only devices need in order to find the data tracks; IIRC writers should be able to find them anyway so it shouldn't be necessary in that case. – Jules Dec 24 '17 at 14:09
  • If your target is an old machine, write the CD at the slowest possible speed. The older CD readers cannot cope with a CD written at high speed. – cup Dec 25 '17 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy