12

I'm fooling around with Matthew Reed's TRS-80 Model 1/III/4 emulator for Windows (TRS32) and am have trouble using virtual cassettes. I am using it to emulate a Model III with Level II BASIC.

I have used the menu to insert the virtual cassette, and the emulator (as expected) creates a new, blank .CAS file. Then I "press" REC+PLAY on the virtual recorder and type CSAVE "FOO". I see the counter advance and the CSAVE completes without error.

(Semi off-topic note -- I had forgotten that CSAVE and CLOAD only pay attention to the first character of the filename you give it.)

Next, I rewound back to the beginning of the "tape", "pressed" PLAY, and typed CLOAD. I see the counter start moving and it advances through to the where it was at the end of the recorded program, but the CLOAD doesn't find anything and just sits there (like it would do on a real system back in the day when it couldn't find a program on the tape).

What's going wrong?

7

I got the same result -- it's a bug. It does work at low-baud rate so you can use that as a workaround. Type L when the Cass? prompt appears at startup.

Looking at the output file the emulator is only saving the sync header of the saved program. I tried this version 1.28, the most recent as of this writing.

I'll send a bug report.

  • 1
    So THAT'S what the Cass? prompt means! While I'm thinking of it, what does the Diskette? prompt mean and what are the allowable answers? – QuantumMechanic May 19 '16 at 20:45
  • 1
    Diskette? means a boot disk wasn't found in the drive. The only "answer" is to put one in and press the big, orange reset button (i.e., it isn't waiting for keyboard input). Or hold the BREAK key and press reset to skip trying to boot from disk. – George Phillips May 19 '16 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.