1

I would like to get working with IBM System/360 on the Hercules emulator.

I use a mac. With macports I have installed Hercules and c3270. Through this site: Running the IBM OS/360 MVT operating system on Hercules ,I followed the instructions and have downloaded the Hercules-ready MVT 21.8 images.

Than I did the following instructed in the 00README.txt file:

Startup:
--------

1.   From the asp directory, start Hercules:

      hercules -f conf/asp.conf

2.   Using a 3270 emulator, start a telnet session to port 3270 for
     device 010.  This is the OS master console.  It must be defined
     and connected at IPL, or the IPL will hang.

The first instruction gives me no trouble.

Concerning the second instruction, I found at this site the workings of the 3270 terminal: Telnet/tn3270 Console How-To for Hercules Version 4 ,

Start an x3270 session and connect to Hercules with the following

Linux:x3270 -port nnnn -model 32xx-x hostname

I assume this works the same for the console version c3270 I installed, thus:

c3270 -port nnnn -model 32xx-x hostname

-port nnnn I replaced with -port 3270

-model 32xx-x with 3279-2 (this seems not so important ?, just about terminal screen size)

hostname with 010 (since in the second instruction in the 00README.txt file it says device 010.)

Thus the whole command is: $ c3270 -port 3270 -model 3279-2 010

This gives an error:

OSX@1:~ $ c3270 -port 3270 -model 3279-2 010
c3270 v3.3.15ga9 Sat Sep  2 12:15:29 UTC 2017

Copyright 1989-2014 by Paul Mattes, GTRC and others.
Type 'show copyright' for full copyright information.
Type 'help' for help information.

Trying 0.0.0.8, port 3270...
Connect to 010, port 3270: No route to host

[Press <Enter>]
OSX@2:~ $

What is going wrong here ?

And what is the meaning of ?:

This is the OS master console.  It must be defined
     and connected at IPL, or the IPL will hang.

Edit 1. (2 feb. 2018 / 21:29) In respect to @wizzwizz4, I tried 017700000001 instead of 010 , as device number, with the following result:

$ c3270 -port 3270 -model 3279-2 017700000001
...
Trying 127.0.0.1, port 3270...
Connect to 017700000001, port 3270: Connection refused

Edit 2. (3 feb. 2018 / 12:10) Solved for another setting

I tried a different setting. On mac os x I have installed Vagrant ,and a vagrantbox for linux 14.04lts. I downloaded from The MVS 3.8j Tur(n)key 4- System the zip-file tk4-_v1.00_current.zip. And I installed with sudo apt install c3270 the telnet terminal emulator in the linux vagrantbox.

In the linux vagrantbox I extracted the zipfile to the folder tk4.

Then I did:

vagrant@ubuntu:~$ cd tk4
vagrant@ubuntu:~/tk4$ ./mvs

Which starts up MVS.

Then in another tab of the same terminal

vagrant@ubuntu:~$ c3270 localhost:3270

That gives the login screen.

Then I could fill in username and password. Obviously this is not solving how to use any version of IBM System/360 etc. directly on mac os x. The TK4 version didn't seem to work on os x and is probably preconfigured for Linux and not os x. However I am glad it does work the other way.

I found this video Mainframe operating system MVS 3.8 turnkey TK4 how to install and operate helpfull. As well as MVS_TK4-_v1.00_Users_Manual.pdf, with information on username (for instance "HERC01") and password (for instance "CUL8TR"(belonging to HERC01)).

  • "hostname" is the name or ip address of the host on which the Hercules emulator is running. regarding the IPL, presumably there is some kind of configuration file that defines the configuration of the emulated system. You need to ensure that the configuration includes a terminal at device 010 otherwise IPL will hang (I infer from this that a real IBM System/360 always had a console terminal configured as device 010) – Ken Gober Feb 2 '18 at 21:01
  • 1
    Note that you can start more terminals by connecting to the same port (i.e., c3270 localhost:3270 again without changes), and they will connect to the other console devices after 010). In the same way, you can do telnet localhost 3270 for a telnet connection. Normally you want at least two terminals, one for the console and one for a user login, but IIRC the MVS turnkey TK4 system moves the console terminal into hercules with the default settings. – dirkt Feb 3 '18 at 21:48
4

010 has a preceding 0. This means "treat this number as octal" which is base-8. This uses the digits 0, 1, 2, 3, 4, 5, 6 and 7. After 07 is the number written as 8 in decimal (base 10), but there aren't any digits left. So, like in decimal, we use two digits: 010 = 8. This looks familiar...

Trying 0.0.0.8, port 3270...

This is interpreting a single number as an IPv4 address. This is done by checking the format of the IPv4 address:

  • If it looks like aa.bb.cc.dd, treat each decimal number as a seperate byte. For example, 123.45.67.89123.45.67.89.
  • If it looks like aa.bb.cc, treat the first two decimal numbers as bytes, but treat the third number as a two-byte literal. For example, 123.45.678123.45.2.166
  • If it looks like aa.bb, treat the first decimal number as a byte but treat the second number as a three-byte literal. For example, 123.456789123.6.248.85.
  • If it looks like aa, treat the number as a four-byte literal. For example, 80.0.0.8.

Apparently, this program not only supports decimal literals but also octal literals. In order to reach localhost (a loopback address back to the requesting computer on almost every modern system) you need to use the IP address 127.0.0.1, which is 0x7F000001 as a hexadecimal literal or 017700000001. So, try that number in place of 010.

This might solve the particular problem that you're having, but I expect that there are still a few others. Specifically, I don't think that's how you input the device number to this program.

0

Not sure if this will help, but this was the answer to connecting the Master Console to an Ubuntu x3270 session on TK4-

010@ubuntu:3270

and then on the Hercules console:

attach 010 3270 CONS

and:

/v 010,console,auth=all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.