3

Can I run Contiki on my Apple IIe without an Uthernet card? For example, I was thinking that I could run my Raspberry Pi to emulate a network card through the serial port as a null modem. Any examples of people doing this sort of thing would be appreciated.

(Yes, I know about A2Cloud but that doesn't put the TCP/IP stack on A2, it just makes the A2 basically a dumb terminal which isn't so interesting to me.)

Update: Looks like someone did the same basic thing on an Amiga, but not with Contiki.

3

I reached out to Oliver Schmidt, maintainer of Contiki for Apple 2 (among other things), and he suggested the following:

You can't "emulate" an Uthernet card with an RPi but you can - generally - use the RPi to get online with Contiki.

* Warning *

I haven't tried what I describe below myself. And I have a report that it doesn't work reliably. And it's quite some effort. Nevertheless...

Instead of using an Ethernet card Contiki can be built to use a SuperSerialCard to connect to a SLIP server. There's no pre-built Contiki for SLIP, you have to build it yourself.

Read https://github.com/contiki-os/contiki/blob/master/cpu/6502/README.md, especially

"The cpu/6502/ directory is used for targeting 6502-based machines using the cc65 compiler http://cc65.github.io/cc65/."

and

WITH_SLIP Default: 0 Purpose: Use SLIP (based on RS232 driver coming
with cc65) instead of Ethernet.

additionally read https://github.com/contiki-os/contiki/blob/master/platform/apple2enh/README.md, especially

"The 'disk' make goal requires AppleCommander 1.3.5 or later. It is available at http://applecommander.sourceforge.net/."

You can either build the individual Contiki programs using e.e.g https://github.com/contiki-os/contiki/blob/master/examples/webbrowser-80col/Makefile or build them all using https://github.com/contiki-os/contiki/blob/master/tools/6502/Makefile

Getting the RPi ready is supposed to be easy, e.g. https://harizanov.com/2013/03/tcpip-over-rfm12b-and-raspberry-pi-as-gateway/ says that something like

sudo modprobe slip  
sudo slattach -L -s 38400 -p slip /dev/ttyAMA0 
sudo ifconfig sl0 192.168.5.1 dstaddr 192.168.5.2

is enough.

Please note that I don't know more about this then what I wrote above.

Good luck. Oliver

I will update this with my progress doing so, and try to post the rebuilt Contiki binaries somewhere as well. Thanks to Oliver for his assistance.

Update: I was having trouble with the compilation, so Oliver was kind enough to compile for me and send along. Here are the compiled binaries if you are interested.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.