8

I picked up a nice Packard Bell Legend 245 over the weekend, and it works great apart from one issue so far: when dragging windows around the screen (Win 3.1), the screen gets corrupted with weird snow-like artifacting (see below).

This only happens if I run Windows in 256-color mode. At 16 colors it seems totally fine. The corruption doesn't appear until you drag a window, save for the odd pixel that gets corrupted when rendering text, and it doesn't happen with every drag (but close to it). The snow remains static, and will travel along with the window if I drag it again, potentially worsening each time.

According to MSD, the video BIOS is "LSI Logic Corp. BIOS Code, Version 10.05.03H". There's a single VRAM chip soldered to the board, labeled "NEC 424170-80L", and I can't find any information about it (such as size). I get the same results whether I pick the Super VGA 640x480 256 colors driver, or the Video 7 640x480 256 colors one.

Does this indicate there's a problem with the VRAM? Or do I just need a different driver?

SOME MORE TEST RESULTS:

I hit the turbo button to slow down the system (probably to around 8 MHz based on how horribly it runs), and the snow artifacts were totally resolved. I then adjusted the jumpers to underclock the CPU from 33 MHz down to 25 MHz. The artifacts were substantially reduced (probably by about 75%) but not gone completely. So whatever is going on, the CPU and main bus speed is definitely a factor. And I would assume the RAMDAC has to read the VRAM twice as fast in 256-color mode vs. 16-color mode.

Let it snow

  • My guess would be that it has a graphics accelerator that has developed a blitting fault. Does the driver offer any option to disable acceleration and/or is there a generic VESA driver that you could try? Possibly in conjunction with FreeVBE or similar. – Tommy Sep 17 '18 at 12:55
  • @Tommy I've only got the stock Win 3.1 drivers at the moment. So far I haven't found anything OEM that came with the machine. Another weird thing it does: it will switch to 800x600 256 color mode, but then the bottom ~25% of the screen is a clone of the top ~25% (in addition to the snow). – db2 Sep 17 '18 at 13:00
  • 1
    Looks like a starting memory fault with fast onsecutive memory access. Reduce resistance (unplug/clean/plug the graphics card, same for all RAM chips (if socketed) and check voltage at RAMs during access as this can be as well due ageing capacitors, not being able to supply the peak switching current for the read buffers during such operation. – Raffzahn Sep 17 '18 at 13:27
  • 1
    @Raffzahn Good idea, I'll start by underclocking the machine (via the Turbo button and/or jumpers) to see if that has any effect. The video chips are all soldered directly to the board, so there's no need to resocket them. Probably wouldn't hurt to clean the pins with a little contact cleaner, though. – db2 Sep 17 '18 at 13:59
  • 1
    VRAM chip ... labeled "NEC 424170-80L", and I can't find any information about it (such as size) There's a datasheet here ... It's a 256kword x 16 bit DRAM. The "L" variant is a 3.3V chip, so there may be a level converter involved somewhere that's failed. – Jules Sep 17 '18 at 16:17
4

Well, turns it it was a driver issue, doing a really good impression of a hardware failure. I tried the suggestion of pushing on the chips to see if any pins were loose, but there was no visible effect. The thing that was throwing me off is that this is supposedly a Video 7 chip, but none of those drivers were actually working on this system.

Closely examining the video chip indicated that the model is a Headland Technology HT216. After a lot of Google searching and experimenting, I was able to track down a candidate driver package for it:

https://www.driverguide.com/driver/detail.php?driverid=66649

NOTE: Beware of all their shady decoy links that try to get you to download their driver manager/agent. The driver is in a 1.16 MB zip file.

Installation is slightly unusual for a Windows graphics driver. First, make sure you've got Windows configured and working with the basic "VGA" driver. Then exit to DOS, and after extracting HTdriver.zip, run SETUP.EXE. Choose the option to install Windows drivers, and point it to your WINDOWS\SYSTEM directory. After installation is complete, launch Windows, go to Control Panel, and open the new HT Display control panel. In here, you can choose your resolution and color depth. Pick what you prefer, restart Windows when asked, and presto! 800x600 256 colors on a 33 MHz 486. (I should really track down one of those 486 Overdrive chips...)

I'm guessing that this GPU uses an unusual framebuffer layout, and perhaps has to monopolize the VRAM bus a bit more than a typical VGA card to push 8bpp out to the monitor. That could explain the strange cloning of strips of the display, and VRAM read/addressing errors potentially caused by bus conflicts. So it was sort of a hardware problem, just thankfully not a failed hardware problem.

Note that the HT216 appears to have been used in multiple Packard Bell models, so if you've got an old Legend with the same chip in it, this could well be what you need to install.

3

You've made good observations and experiments to start making some conclusions:

it will switch to 800x600 256 color mode, but then the bottom ~25% of the screen is a clone of the top ~25% (in addition to the snow).

This means that video chip reads wrong location of the RAM. I suspect you do not see it in 640*480 because that location is not used. However it is a good question how VRAM is organized, and requires datasheet for the VDP. What is the video processor installed?

The snow remains static, and will travel along with the window if I drag it again, potentially worsening each time.

Shot is good enough to see that colors are not arbitrary, but dots are kind "out of context" - they must be in some location of the screen, but they appear in wrong place. It means that VDP reads from wrong VRAM location, and, per my educated guess, when you drag windows driver uses hardware acceleration to move the screen area, which uses boosted clock (I am speculating here).

As you say they are worsening each time it means not that VDP only reads data wrongly, it performs read-modify-write wrongly when running hardware acceleration.

I would love if this issue can be solved by the replacing caps and marginal power problem.

The first thing you must do is taking magnifier and look at the chip pins looking for cold joints or any defects related to conducting or non-conduct. In addition you can perform simple test - if you can run PC in disassembled shape try slightly pressing on chips - VRAM and VDP (probably other interface chips) dragging windows to see if action affects quality of operation.

Actually issue in 800*600 mode shows either broken component (issue in its logic of operation), or bad contact (or other way around - good contact when it should not be there - e.g. shortage of address lines to power supply rail through some resistance).

But at the end it may happen that problem is wrong driver :) or its settings. Dig into driver settings, control panel (or how it was called in Win 3.11), and of course BIOS.

  • 1
    Yes, it's Control Panel in Windows 3.1; it even says so right in OP's screenshot :) – a CVn Sep 18 '18 at 15:35
  • To rule out the driver/windows issue I thought to propose running some DOS game, but I fail to suggest any at 800*600 256 colors. All come to mind are 320*200 (e.g. DOOM, Dune etc). While writing this I actually asked myself a question - does this machine really support 800*600 properly??? I am having issues finding specifications for it. – Anonymous Sep 18 '18 at 15:50
  • Fractint is a good way to test various video modes in DOS. As far as games go, Duke Nukem 3D supports quite a few SVGA modes. – Stephen Kitt Sep 18 '18 at 15:58
  • All excellent observations, thanks. I'll experiment with chip pressure, and see if I can find a good magnifying glass. The GPU (if you can even call it that) is a Headland Technologies chip. Don't have the model number in front of me. And yes, it does do 800x600 if I leave it in 16-color mode. No problems there. It's the 256-color modes failing. I think Warcraft II runs at 640x480 256 colors, so that might be a good test. Don't know if it does VRAM reads for map scrolling, though. Oh, and it was Windows Setup, not Control Panel. Didn't have the Display control panel yet in 3.1. ;) – db2 Sep 18 '18 at 16:47
  • Regarding games with high res display modes, SimCity 2000 is one that I recall having a good set of options. – Jules Sep 19 '18 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.