1

My computer is saying that my netscape file is being used by a host that says it is located in Boulder Colorodo. It is coming from a wierd IP address. I just plugged my ethernet cable to use the internet, and it worked, but I cannot find the lock file so I can delete it. Can I have some assistance?

My Question is: How do I find and delete the lock file in the SGI Indy computers.

  • 1
    Please be more explicit in your question about how it relates to retrocomputing, or else it is really better addressed on another SE site. – Brian H Sep 27 '18 at 1:49
  • While an SGI Indy might be well on topic here, it would need a lot more in information to solve your problem. Starting with what OS and Application this is about, and ofc, a more detailed error description. And how that was gathered. – Raffzahn Sep 27 '18 at 2:25
  • 1
    tried sudo rm /.netscape/lock ? – Tommylee2k Sep 27 '18 at 7:38
  • I'd vote to re-open this if I had the rep. From What topics can I ask about here: "Questions are welcomed on how to use or preserve computing equipment that is no longer manufactured or supported by the manufacturer. Hardware, including peripherals and Software, including operating systems and applications are in scope." – Blrfl Sep 27 '18 at 14:52
  • @Blrfl As far as I'm aware, that text (help/on-topic) matches community expectations, but it hasn't been edited from the "temporary" version I threw together about half a month ago. More to the point, are you saying that because it's about Netscape, it's on-topic? I'd be inclined to agree with that sentiment. – wizzwizz4 Sep 28 '18 at 6:12
7

Netscape uses a lock file to prevent corruption of its internally-used files that would happen when two copies of the program are running at the same time. This file is stored in the user's home directory under .netscape/lock.

I don't have an old enough system to test this out for myself, but Firefox, which adopted many of Netscape's habits, creates a lock file that's a symbolic link to a nonexistant file that contains the IP address of the host that created it and the process ID, like this:

% ls -lh .mozilla/firefox/*/lock
lrwxrwxrwx. 1 blrfl blrfl 17 Aug 23 20:33 .mozilla/firefox/angfgbte.default/lock -> 192.168.1.111:+1234

In the era when the Indy was built, it was common to have home directories served up to the workstations across the network so users could log into any of them and get at their files. Storing the IP address where the first instance of Netscape was running would let a second instance inform its user where the first was running.

What likely happened in your case is that the machine was running Netscape when it was last shut down or lost power before you got it, leaving the lock file in place. (I don't remember if Irix of that vintage neatly terminated running processes during shutdown.) When you started Netscape back up, it had no way of knowing that it wasn't on the same network, saw the lock file, refused to start and gave you the best information it had about where the other process might be running.

The way to solve the problem is to remove ~/.netscape/lock and start Netscape.

  • None of those things work. And the IP address is different than the one my computer uses. – rjhwinner03 Sep 28 '18 at 20:05
  • @rjhwinner03 How are you starting Netscape? From the command line or somewhere else? – Blrfl Sep 28 '18 at 20:14
  • Just using the toolchest menu that IRIX gives. – rjhwinner03 Sep 29 '18 at 5:05
  • @rjhwinner03 If you're using some kind of graphical finder to look for the file, open a terminal instead. Sometimes they hide files and directories whose name begins with a dot in visual representations. What I described is how Netscape works; that file is on your local machine somewhere. – Blrfl Sep 29 '18 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.