How do I compile my code that I have typed on my SGI Indy computer? I have already tried to install the GCC/G++ compilers, but when I run my application, I get the error that says:

gcc: installation problem, cannot exec 'as': No such file or directory

Do you know where 'as' would possibly be at so I can run my source code?

When it tried to run the code, I typed

gcc -o Game Game.cpp

I am having to use a C++ file for my C code because stdio does not exist in my computer, and cstdio uses stdio. IOStream was my last most bright option, so I error message above.

I do not really know what I am doing when I installed gcc from SGI's website. I just winged it...

P.S. the capitalization is exactly how it is written on the screen.

  • 2
    "as" is the assembler. Sep 29, 2018 at 19:41
  • 1
    Don't know how you did install gcc, but as is part of the GCC binutils package. If you bootstrapped and compiled gcc from source, it should also be somewhere in the source tree.
    – dirkt
    Sep 29, 2018 at 20:07
  • 3
    A proprietary unix like IRIX would also have its own assembler (and linker etc.) and gcc could be configured to use that one instead of GNU binutils.
    – user5152
    Sep 29, 2018 at 22:17
  • Where do you get the idea that stdio does not exist on an Indy? nixdoc.net/man-pages/IRIX/man3/printf.3s.html Sep 29, 2018 at 23:01
  • 2
    If you type as on the command line, is it found? as is the assembler. If it's installed, you'll need to tell gcc where it is when you install gcc. If it's not installed, you'll need to get it and the Irix equivalent of the other programs in binutils.
    – JeremyP
    Oct 1, 2018 at 9:32

2 Answers 2


The SGI builds I have seen require you also have the MIPSpro tools installed on your Irix system as gcc does not include an assembler.

It is possible to cross compile a gcc and binutils for Irix on a PC however you'll still need the headers and libraries so I am not sure you can avoid needing MIPSpro or the IDF/IDL developer library CD-ROMs even then. You will probably also need a matching libg++.


Here's the start of an answer. Run this command:

gcc -print-search-dirs | grep '^programs:'

That will tell you where gcc thinks as, the assembler program, ought to be. Then run

find / -name as -print

That will tell you where it actually is, if you have one installed.

If you don't have an as anywhere, you could try the downloadable MIPSPro CD ISO files on archive.org. It's not clear if you need a license file to run MIPSPro's as, but if you do, you're probably stuck, because those license files have to be generated for specific machines, and I don't think anyone has the generator for that since the remains of SGI abandoned Irix.

Another place to try is irix.cc, which seesm to be where the Irix people hang out these days.

Yet another is winworldpc.com.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .