3

The problem is basically as the title stated. I have a Compaq Presario PC from the late 90s running Windows 98 Second Edition. It was handed down so I'm not exactly sure what it went through in its original years. I'm trying to get it to network one way or another now. I have USB support working, so I can plug in flash drives, which is nice, but I'd like to use the NIC and/or a modem with it.

I tried using the original Compaq 56k internal modem but could not get it work. I spent hours trying. I would get "Could not connect to COM port" when doing modem diagnostics (it was on COM2). HyperTerminal would throw errors too.

Didn't have a NIC so I installed a DAVICON 9102 10/100 Mbps network adapter from a Dell Dimension 8200 running a corrupted installation of Windows XP. The light on the NIC lights up when the computer is on (and both if a cable is plugged in) but nowhere in the computer can I get network or Internet access. Yes, I played with the firewall settings.

I recently got an external US Robotics 5686E modem to see if that would work more seamlessly. Plugged it in, didn't work. The modem is in perfect condition. When I try doing diagnostics I see lights on the modem flickering but the computer hangs and then says could not communicate with modem. Yes, proper drivers were installed.

Oh, also, before that I installed the modem that was on that aforementioned Dell computer and that also didn't work, even with the proper drivers installed.

Someone suggested possibly Windows needs to be repaired using the upgrade disc. I suppose that's plausible, but I'd like to pinpoint the actual cause of the issues. I reinstalled the USR modem numerous times before realizing that was going nowhere.

If it helps, after I installed the NIC/internal Dell modem (I installed at the same time so not sure which) I now get some kind of network error upon each boot that says something like "NDISHLP.SYS not found". Not sure if this is related or not. Seems to be a possible NIC issue but not sure why that would be affecting the computer's ability to communicate with internal and external modems. Here is what I get from that:

C:\>C:\WINDOWS\net start
  Invalid value for binding specified
  Invalid value for binding specified

Error loading device driver NDISHLP.SYS.

Error 7323: One or more network transport drivers failed to load.


C:\>
C:\>
C:\>
C:\>PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;"C:\Program Files\Mts"

C:\>

Here are some more pictures:

enter image description here

enter image description here

UPDATE:

Yesterday, I burned a retail Windows 98 SE disc and used that to run "sfc", and I also manually re-copied over NDISHLP.SYS - I now have all the stuff I was told I need except for the LANMAN directory and protocol.ini and the elink thing, both pertinent to the NIC. I also removed the two Ndis2 adapters in Device Manager with yellow exclamation points. When trying to update driver it said most recent driver is already installed, and if reinstalled it doesn't change at all. However, the modem is still NOT working.

Ignoring the NIC, for the present, the computer is still not communicating with the modem. The modem works, and lights DO light up when I click "More info" in Diagnostics.

Upon boot, I no longer see "The network resource cannot be found", I just see this now:

C:\>rem - By Windows 98 Network - C:\WINDOWS\net start

C:\>
C:\>
C:\>
C:\>PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;"C:\Program Files\Mts"
  • have you tried connecting two W9X computers? w2k, wxp and latter on changed something in LAN protocols so file sharing and exploration usually do not work between W9X and W2K/XP/W7/... as usually MS is incompatible between its own versions. PING however should work (in case you install and set the TCP/IP correctly). In case of IPX usage IIRC that one is not installed automatically and need to be installed manually. Once I got also a problem that one machine got installed a RING instead of standard LAN. They look the same but use different cable and architecture. What cables you are using? – Spektre Oct 27 '18 at 8:07
  • Coax or UTP ? in case of coax you need terminators ... also cables have different Bandwiths make sure you got the right one ... sometimes is safer to set the 10/100MBit/s and duplexity manually in network adapter settings ... That should be all in a nutshell for LAN. Sorry but I do not have any experience with modems – Spektre Oct 27 '18 at 8:09
  • 1
    @spectre - the win9x/2k file sharing incomparability is caused by the shift to encrypted passwords. It can be disabled on the server (there's a registry setting, which should be easy enough to find with a google search), but it doesn't sound like that's what's going on here. If I had to guess, I'd say that a core network component in the os is either corrupted or has been deleted (possibly to save space). – Jules Oct 27 '18 at 8:38
  • @Jules that sounds like that would describe my problem. This is regular UTP folks, I just plugged a working Cat5e cable in. I tried pinging major sites as well as my router and neither worked. A core network component in the os corrupted or deleted would sound right but not sure how I could get it back. Would repair find it? – InterLinked Oct 27 '18 at 10:04
  • Just wondering, when you open the network configuration, is "Client for Microsoft Networks" selected? Does the TCP/IP give you options like Dial up adapter? – cup Oct 27 '18 at 21:36
1

Things you need for real-mode Network access in Windows 98:

  • \AUTOEXEC.BAT: Autostart file, should contain a proper NET START, e.g NET START WORKSTATION command.
  • \CONFIG.SYS
  • \MSDOS.SYS should contain a HostWinBootDrv statement in the Paths section to tell where to load the network driver stuff, and a Network=1 statement in the Options section to activate networking. The file is read by NET.EXE.
  • \LANMAN\PROTOCOL.INI Configuration file for PROTMAN.EXE. This is where you tell the system about your NIC driver (example for a 3Com card, yours may vary):

    [ELNK3$] DriverName=ELNK3$ IOAddress=0x300

    [protman$] priority=ndishlp$ DriverName=protman$

    [ndishlp$] DriverName=ndishlp$ Bindings=ELNK3$

    [data] version=v4.00.950 netcards=ELNK3$,*PNP80F7

    [NETBEUI$] DriverName=NETBEUI$ sessions=10 ncbs=12 Bindings=ELNK3$ Lanabase=0

    [nwlink$] DriverName=nwlink$ Frame_Type=4 cachesize=0 Bindings=ELNK3$

  • \WINDOWS\ELNK3.DOS NIC-specific driver, referred to in PROTOCOL.INI

  • \WINDOWS\NDISHLP.SYS Networking support, loaded by PROTMAN. You need this, and it should be with your Windows installation files. Get it from somewhere, that is the first problem on the list

  • \WINDOWS\NET.EXE User-level Network application, you seem to have that

  • \WINDOWS\NET.MSG Resources for the above

  • \WINDOWS\NETH.MSG More resources for the above

  • \WINDOWS\PROTMAN.DOS Real-mode driver for PROTMAN

  • \WINDOWS\PROTMAN.EXE Protocol manager, loaded by NET.EXE

The rest of the network configuration sits in the registry. You should be finding these keys, and if not, create them (but don't ask me about the values... Most of these should be set by Network Config dialogs in Settings):

[HKEY_LOCAL_MACHINE\Enum\Network]
[HKEY_LOCAL_MACHINE\Enum\Root\Net]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network] 
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetClient]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetService]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWLink]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR]
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VREDIR]

Windows 95 and 98 didn't come with as many drivers for expansions as later systems like XP or Windows 7 did - You normally got the drivers with the hardware and had to install them manually. You should be looking for a DAVICOM 9102 driver install disk, and a similar disk for the modem - Install these and you should be one step further.

  • Actually I see Ndishlp.sys in the Windows directory, which is strange. I am missing Protocol.ini as I don't even have a LANMAN directory at all, nor do I have elnk3, nor the second to last and third to last registry keys – InterLinked Nov 1 '18 at 20:59
  • You don't have a 3Com card, but a Davicom instead, that is why you don't have eknk3 drivers - The drivers for your card should come with the card, or you should be looking for a replacement driver. Googling "DAVICOM 9102 Windows 98" comes up with a number of hits. Install that driver set and it should work. – tofro Nov 1 '18 at 21:11
  • I have now created the missing registry entries and have EVERYTHING except the LANMAN directory and elnk3. I do have the NIC and modem drivers installed. The modem (leaving the NIC alone right now) is still not working. I updated my post with the latest troubleshooting I did – InterLinked Nov 4 '18 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.