2

I've got a Packard Bell Legend 245 that's been running a 486 DX at 33 MHz. The board is Socket 2, and says Intel Overdrive Ready. I bought a 66 MHz DX2 under the assumption that it's just a drop-in upgrade. When booting the machine with the DX2, the message "Unexpected Interrupt In Protected Mode" will usually pop up once or twice (not consistent) sometime between the memory test starting, and the "Starting MS-DOS..." message appearing. It will boot DOS after that.

What I've checked so far:

  • Booted with the 16 MB SIMM removed (leaving only the 4 MB on the board), to make sure it wasn't faulty RAM.
  • Dropped the bus speed down to 25 MHz, thus running the CPU at 50 MHz, in case it had drifted out of spec due to age/damage.
  • Looked at the board/jumper reference sticker inside the case to make sure there aren't any jumpers that have to be changed for a DX2.
  • Looked up the chip details and confirmed the DX2 is 5V.

I have not yet tried pulling out the sound card, ethernet card, or CD-ROM IDE controller card, and I have never seen this message appear when using the original 33 MHz DX with everything else remaining the same.

I'm gunshy about doing too much with the machine, even if it does appear to start DOS okay, in case of causing disk corruption. What does this error message suggest that I should try doing?

EDIT:

Here are the markings on the two CPUs, as well as the 33 MHz 486 SX that originally came with the machine (which I replaced with the DX). All three are the same type of package.

SX: A80486SX-33 / L3041692 / SX680

DX: A80486DX-33 / L2522713 / SX419

DX2: A80486DX2-66 / C4250445 / &E5V1X SX807

Update after some more experimentation:

After making sure I had a fresh backup, I popped the DX2 in and did some testing. After the usual errors that popped up during the memory test (which still passed just fine), I didn't notice any further problems. I started up Windows, copied some files over the network, hopped on IRC for a bit, tested a few games (still a little sluggish; probably a memory or I/O bottleneck that needs some L2 cache), etc. Then I went out to DOS and tried Doom. High-detail mode ran much more smoothly than with the 33 MHz CPU, and I had no problems playing, outside of getting myself killed by falling off a ledge like an idiot. :P

So, it seems like everything was working fine, apart from that strange error message that pops up intermittently during POST. I'm still a bit nervous about running with it full time until I can be more certain that this doesn't indicate potential for data corruption.

4

What processor did you buy/use exactly? A DX2 isn't the same as an Intel 486- Overdrive. It got a different power regulation and ignores certain settings. Also the pinout differs, as there are two versions ODP and ODPR, depending on the mainboard. As said before, both are not regular 486DX2 CPUs but special variants.

Also, if this System is a Socket 2 System it doesn't run with a 486-Overdrive, but needs a Pentium-Overdrive version of a P54C, made to run with the 32 Bit 486 Bus and a single 5V power supply (instead of the 3.3V of a regular Pentium).


The markings (&E5V1X) tell it as SL Enhanced (&E) 5 Volt (5V) Desktop (1X) processor. Packaged in June 1994 in the US (C425).

As supected. It's not an Overdrive but a regular 486. So the BIOS will mistake it as DX (they share the same CPUID), thus it should work. Of course not faster than the original one, as the clock multipliers may not be set accordingly. In fact, this might also be the reson, if these pins are not handled by the board as the CPU expects.

Or, as usual, it's just broken in a freaky way.

Long story short, you want to look for a Pantium Overdrive, not a 486. Or some third party faster 80486 - like a 100 or 133 MHz AMD - with an apropriate PCB for multipliere setings.


Further: The SX419 is the original, first DX-33 of ~1990 (this one is of December 1992).

SX680 is again the original first series SX-33 (here of January 1993) without SL enhancement

  • I've added the markings from the chips in play, in case those offer some clues I'm missing. None of these chips have the "Overdrive" branding on them; that's just a detail of the socket itself that may or may not be significant here. – db2 Nov 1 '18 at 11:25
  • 1
    I've seen old Evergreen "586" upgrade chips floating around still. I had surprisingly good luck running one of those in my old 486DX50 in clock tripled mode. Pushed it to 150mhz and it was not stable in apps that spent tons of time in protected mode (djj4gp for example IIRC the name correctly), but was fine for normal DOS apps/games, and even DESQview. – Brian Knoblauch Nov 1 '18 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.