I have an A600 Rev 2D (schematic), which is dead as a doorknob. It was that way when I acquired it some years ago, and it's mostly been in storage since.

Between the 5V rail and GND I measure a low resistance, only around 115 to 140 Ω, and that doesn't seem right. Removing all the electrolytic capacitors did not help. There has been some slight electrolyte leakage from the 10 μF caps, as evidenced by a fishy smell when I desoldered them, but no visible corrosion on the board. After removing the caps, I cleaned the surrounding PCB areas with isopropyl.

Unloaded, the PSU gives out all the right voltages, and it works fine with my A500.

When I connect the PSU to the A600 motherboard, the 5V rail drops to near zero. I have tried feeling the temperature of the chips while they're powered, but nothing gets noticably hot. Maybe the PSU goes into some safe shutdown when it sees overcurrent?

I feel kind of stuck at this point, all I can think of is to start desoldering chips until the short disappears. But that seems like a ham fisted approach.

Has anyone experienced similar symptoms? Any tips on how to continue troubleshooting this problem?


I tried the alcohol test. I set the current limit to ~1A, which limited the voltage to a bit over 2V.

Agnus, Denise and both of the CIAs dried up somewhat quickly in the center, but that I suppose is to be expected.

But the DRAM was acting odd: U17 (which is optional according to the datasheet) stayed cool, while U16 (which I suppose is the main DRAM chip then) dried up very quickly.

U22, which is a 74LS245 octal bus transceiver also dried somewhat quickly. While U21, also a 74LS245, stayed wet. Both of these sit between the CPU and the DRD bus (DRAM Data Bus) that goes to Agnus, Denise, Paula, and both DRAM chips.

Not sure what to make of it all yet. Perhaps I should increase the current to 2A to really see the effect, but I'm afraid of cooking something that shouldn't be cooked.

I guess my primary suspect at this point is the U16 DRAM chip.

  • 1
    yup! welcome to retrocomputing : )
    – Badasahog
    Nov 17, 2018 at 23:15
  • So single one of several dram chips getting hot quickly is clearly a suspect.
    – lvd
    Nov 18, 2018 at 16:46
  • I desoldered the chip. Unfortunately, the measured resistance between +5V and GND was unchanged. I then upped the amp limit to 2A to see if anything got really hot, but then the A600 happily started drawing 1.75A at 5V. I'm starting to wonder if I've been chasing a red herring all along. Perhaps measuring 140 Ω between +5V and GND is not abnormal after all? It's clearly not a resistive load.
    – Dampmaskin
    Nov 18, 2018 at 16:49
  • 1
    Measuring resistance of the semiconductor devices is near to useless. That 'resistance' will depend on the current injected by the measuring device, the most representative case is the 'resistance' of the diode.
    – lvd
    Nov 19, 2018 at 8:00
  • 1
    Based on a datasheet for the HM514260AJ8, the desired 18-bit address is split into a 9-bit row and 9-bit column for both reads and writes. As shown on pp. 134-143, the row is placed onto the address bus and latched on /RAS falling; the column is then placed onto the address bus and latched on either /UCAS or /LCAS falling. For fast page mode the row will be latched once and the column will be latched multiple times. TLDR: the address is split over two cycles. Nov 19, 2018 at 19:05

2 Answers 2


Here are a couple of things you could do to try to localize the issue:

  • See what the current flowing out of the PSU is during and after power-on. That will tell you whether it's sensing a short and shutting itself down. Since you've already determined that there's anomalous resistance between +5V and GND you can probably skip this.
  • Hotspots on the board may indicate shorts. Power on the the system and use an IR camera to look for hotspots. If you don't have one, try putting some 90% denatured alcohol on the chips, etc. and power the system on. The alcohol will evaporate the quickest on any hotspots.
  • With the power unplugged, move along the VDD and ground lines with a multimeter set to resistance mode. The measured resistance should drop as you near the fault. Obviously, you won't be able to measure through the solder mask so just choose pins/leads that are along the rails. Note that diodes may appear as shorts using this method; if you run into this just switch your probes between the two rails.

Somewhat related, Dave at EEVBlog did a teardown/attempted repair of an A500 (Youtube) that might be worth a watch.

  • Thanks. I think at 137 Ω, a difference of a few mΩ will be difficult to spot even with my best meter. So I will try the alcohol method instead. If I feed it a current limited 5V from my "bench" PSU, the current will be 40 mA, assuming that the short is resistive. That will dissipate 180 mW, hopefully enough to evaporate some IPA. But if the current increases exponentially with voltage and hits the current limit of the PSU, that means I can control the heat dissipation, which will make the hotspot much easier to find. In either case, I will try it out and report back.
    – Dampmaskin
    Nov 18, 2018 at 12:27

115-140 ohms doesn't actually sound that crazy, and ignoring the dynamics of semiconductor loads, only equates to around 30-45mA. A normal, working A600 will consume well over 1A. So it doesn't sound like a short to ground to me, and limiting the 5V rail to 1A is likely going to result in a lower power supply voltage as it's simply not enough to power the machine.

The A600 motherboard has a via for the 5V rail that's very close to pads on the -12V rail. It's hidden beneath diode D576, and is very close to C306 - a 10uF electrolytic very prone to leaking, and having already leaked in your case by the sounds of things. The via in question frequently gets corroded when the capacitor leaks, and the resulting corrosion ends up reaching the nearby pad of the diode in the -12V rail while remaining hidden from view by the large diode. This causes a partial short between +5V and -12V, which can cause all sorts of PSU issues without appearing as a short to ground. This is a fault I've seen and repaired on a number of occasions, and it's now the first place I look when presented with a dead A600. Similarly, if you used hot air for removing or replacing the capacitor, it's possible for solder from the diode's pad to bridge to the damaged via, causing a more serious short, but also more easily detected with a multimeter.

I would remove the diode entirely, check the rails for low resistance between them, and clean up the via as it's required for the power supply to the Paula chip, without which the machine won't boot. Once it's all working and happy, you can replace the diode and check afterwards for any solder bridging as a result of the repair.

The nearby 1 ohm resistor R309 is in the Paula 5V supply path, and similarly hides a via (to ground this time) that is regularly damaged by leakage. This is worth checking out for the same reasons as it can also short to the 5V pads of the resistor. However, given the resistance measured between ground and 5V on your board, I don't expect this is the issue here.

  • 1
    All the 10uF capacitors smelled somewhat fishy when I swapped them out, but no visible corrosion. And yes, it seems the cause of the problem was that the old PSU was too weak. I gutted the PSU and gave it a Mean Well RPT-60B, and that solved it. I'm now running the A600 with a Vampire, an IDE2SD, an A604n, an RTC, and a PCMCIA2SD, and it is stable.
    – Dampmaskin
    Mar 26, 2019 at 10:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .